Formatting won't save. Open file, text is highlighted in black. Set highlight to none. Save file. Open file. Text highlights are black again. Repeat.

I was given a Powerpoint file with some titles and some text. Much of the text is just black fields. If I select and change character formatting on every individual field, to NONE on highlighting, it becomes readable. But it won’t save as displayed. I thought I repaired the file and saved as .odp and outsmarted the person who said Powerpoint must be used. Not only do the black on black highlights return when opening the file, it doesn’t appear possible to select all text in all slides and fix them globally, which would be nice. How can I share the offending file or include a screenshot?
I’m sorry I can’t ask just a single question.

Share a sample file. Attach it to your question or use file sharing services such as Google Drive or Yandex Disk.

Text shows up as JUST BIG BLACK LINES ( a Google Slide imported from .pptx). I’m guessing its poor formatting within the .pptx file.
(I wanted to share the .pptx file as I think it may demonstrate poor importing in LO, but I couldn’t remove the slides with personal information so I didn’t share the Microsoft format file.)

Never saw option to attach sample file.

The individual slides with personal information I deleted from .odp, and this smaller file is available as: Text-Is-Black.odp - Google Drive

It should still have the property that repaired highlights cannot be saved. Knowing the problem within LO might still uncover the LO problem in importing .pptx. Again, guessing.

Try not to modify my original file. Thanks all!

I downloaded a copy and confirm the problem. The funny part is that the document prints out without those black rectangles. Even funnier: if I set the fill to none, font color to automatic and change the font face to something else, the problem is gone. Must be really some garbage from PowerPoint.

For the record: I opened the file in Apache OpenOffice 4.2.0 (an ancient development build) and it was absolutely fine. This makes me think there is a problem about LO 7.1.3.

Sorry, I forgot to include version on the OP. See below if interesting.

Astur, how do you know what fonts are missing?

Is there a way to change all the highlights to none for the entire file, instead of
one field at a time?

Did you open in G Docs or G Slides? For me Docs was not an option.

Version: (x64)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 6; OS: Windows 10.0 Build 19041; UI render: default; VCL: win;
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Using a hard-coded color will save correctly. Good workaround for most slides. Using ‘none’ instead of a highlight color is what doesn’t save. So far, no workaround on that one slide with gradient background.

Astur, it doesn’t look like you have the color gradient from pink to blue on Show Your Love.

Google Slides isn’t going to help me for a solution. I repaired the highlights to “transparent” in G slides, downloaded the repaired highlights as PPTX, and of course, the black rectangles return. Another observation: I cannot save in a G slides format that can be placed on Dropbox for other people to use.

(I could swear I added this response a few days ago).
My formatting problem is not with the background. The text is independent of the background.

So do I have a LO bug?