Formulas look weird on certain computer?

I’m having issues with formulas not displaying correctly on my desktop computer (running Windows 8.1). Whenever I create a formula, the symbols don’t align correctly, and they’re too small.

The ugly formatting happens both when inserting formulas into Writer, and when viewing them directly in Math. Here are some examples:

{lim g( x)} csub{x toward 0} = 0

looks like this:
Note that the “toward” arrow is very small and not centered horizontally.

f_i(x) = {prod csub {{j = 1, j <> i}} csup{n} (x - x_j)} over {prod csub {{j = 1, j <> i}} csup{n} (x_i - x_j)}

looks like:
Here, the pi doesn’t have serifs, and it’s not aligned with the stuff above and below it.

abs {g(x) cdot h(x)} <= abs {g( x ) cdot M}

looks like:
Here, the <= are weird, and the cdots are so small and off-center that they’re practically absorbed into the parentheses.

Here is a screenshot of how those three formulas look on my laptop (Win 7, running the same version of LibreOffice) for reference:

I currently have LibreOffice, but this issue also happened with past versions. I have tried a complete un-install and re-install. I haven’t changed any display settings.

Any idea of how to fix this?

That is likely a problem caused by fonts. Make sure, that on the Windows 8.1 PC the font “OpenSymbol” is installed. The font file is opens___.ttf and the current version is 102.6. You can get it from

If the font “OpenSymbol” is not present, then a replacement font is used automatically, and that one might be not suitable for special characters.

In addition look in Tools > Options > LibreOffice > Fonts whether there is any font replacement active.

Formulas first show a replacement picture. If the formula does not follow a change in settings or font, you have to refresh this pictures. Double click the formula or -in case of lot of formulas- use a macro.

OpenSymbol was already installed. I tried downloading the latest version and replacing the old one, but it didn’t make a difference.

I checked, and there is no font replacement active.

Then the formula might not use OpenSymbol, but another font. Please write a pure formula (a .odf file), unzip it and look in the part settings.xml which font is set for FontNameFunctions (and the other FontName…). Then look at the Windows 8 PC, whether this font exists.
If you do not know how to do this, attach the file here or provide it for download.

It seems that the new font rendering driver in Win 8 cannot handle the OpenSymbol font file correctly.
Therefore I’ve patched the font file so that it works with Windows 8, too. You can find the latest version of this patched file (and the discussion about it) here:

If you have any problems with this version of OpenSymbol, e. g. missing glyphs, please let me know so that I can correct it.
(For the formulas in my documents the current version works perfectly.)

Thank you for this solution. I expected the same problem as topic starter did.
There is one more symbol that is represented incorrectly: it’s small vector arrow (“vec” in formula editor). Not so problematic because “widevec” may be used instead, but the fact is.

I came across this annoying “feature” just now. I tried the remedy of installing the new opensymbols fonts but that it was not totally satisfactory. If I exchange the impress documents between linux and windows 8.1, I have to rework all the formulas (open it once and close them) to have the correct appearence on the screen. Also in linux the export to pdf is only correct if this is done, otherwise the formulas are spoiled.
If this stays the use of libreoffice is seriously hampered!