Frame Style Position

First, this is in Writer 7.0.0.3, on Windows 7.

So I’m building a template for others to use and it needs to be able to make pretty frequent use of frames for sidebar text and annotations. I’m hoping to set up one or more global “Frame Styles” to make everything more consistent and make implementation of them faster. I’m running into a pretty big hurdle, though, with frame positioning.

My document is almost always in two columns throughout. When manually adjusting a given frame, I can make it stay in one column by setting the size to “100% Relative to Paragraph” and the Horizontal Position to “Center relative to Paragraph Area.” Unfortunately, this latter option doesn’t seem to exist at the global level. I can only set the horizontal position relative to ‘Left Page Border,’ ‘Right Page Border,’ ‘Entire Page,’ or ‘Page Text Area.’ If I select this last option, it centers the frame across both columns as if they aren’t there.

Am I missing something, or is this just a glaring oversight/limitation in the way (global) Frame Styles are implemented?

On a separate, but related note, I’ve noticed that when you anchor one frame within another, the (local) position options reference the outer frame, but the vertical ones don’t seem to do anything, that I can see. Writer seems to ignore whatever option you choose, according to my tests.

Are you sure you create/define/modify frame styles?

Frame styles are listed in the side style pane (F11) when you click on the third small icon in the toolbar.

I experimented with a small document according to your specification. I used the Frame style with a right-click and Modify.

In the Type tab, the Horizontal Center position is offered and works as usual.

I don’t recommend setting size as 100% Relative to xxx, because this size is converted to some absolute size and if subsequently change the “environment” (e.g. changing the number of columns), your frame will not adapt to the new environment.

Don’t forget to set Wrap mode to avoid to draw the frame above your text.

There is a small “glitch” with frame styles: when you modify them, the changes are not automatically transferred to the frames. You need to assign another style and restyle with the modified style to see the changes.

Regarding your comment, depending on how you inserted the “nested” frame, it might have been located outside the initial frame. Have you enabled the various View options, notably View>Formatting Marks and View>Text Boundaries, to see exactly what you’re doing?

Test done with 6.4.6.2

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

Interesting. I went to double-check the results against what you’re stating, and ended up troubleshooting myself into the solution. I was on the “Frames” section of the style toolbar, but not inheriting the default “Frame” style.

If you create a new Frame Style that does not inherit “Frame,” then you get the behaviour I mentioned above. If your custom style does inherit “Frame,” then you’ll get the behaviour you describe. I assume it has to do with hardcoded differences between the way some of the various frame types are implemented. I was hoping to have my custom styles separated from the default ones as much as possible, but some battles can’t be won. C’est la guerre.

Regarding the nested frames, I’ll have to do some more testing and start a new question if I can’t figure it out. I can say, though, that the horizontal positioning relative to the outer frame functioned as expected, but the vertical did not.