FTP Server problem

Hi there. I am having trouble connecting my FTP server to Libre Office, to directly access my files there. After i complete the settings in remote files, i am getting the message “General input/output error”. I am certain about the correctness of my settings, i have access to my FTP through various devices etc. Any ideas?

If I configure File>Open Remote File as I would for any other app, I get Access denied. Apparently, LO’s FTP implementation already points the current directory to user’s home.

To get access to your files, leave Root: parameter blank. This will point you to /home/<User> and navigate to the proper directory with the open dialog. If you want to point Root: somewhere else, fill in a relative path (even though there is already a / at the beginning, /home/<User> will be added at head).

It is likely that … path fragments are filtered because I could not point to /home or sibling directories.

My explanation is valid for Linux, adapt for other OS’es.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

Hello and thanks for your comment. I have actually tried to fill in the proper home folder for my FTP (which is not in the form of /home/user) but still no success. No success by leaving it blank too

When you leave Root: blank, where does LO point (in case you have some success)? It seems something is definitely weird because i’m only allowed to go into my home directory.

I’ve tried connecting in SSH instead. It works better: I can point anywhere, provided I have access rights.

PS: you should have posted as comment since this is not really an answer.

you’re right… it (by default i guess) points to the / folder, without any success though. My FTP server is a NAS, not a unix-based one.

Then, try to switch to SSH. That’s how I connect to a friend’s NAS.