Full justification issue

I once noticed that my libre office version used to have a nice justification, with spacing beetween characters to avoid large blank spaces. I don´t know what I did to obtain this feature, if it was a version thing or something else, the fact is that when I reinstalled my OS and libreoffice software, the feature just disappeared… I thought I was mistaken for this feature, but I have some pages printed that use this feature. I researched a lot, but no solution to my issue was found. The closest thing to a solution was installing WPS Office and using its “smart” justification, which is not very smart, as last line of paragraph gets justified also (which wasn´t on libre office. Please, any help would be great! Thank you.

Supposing your concern is what is called “leading” in typography:

Afaik you only can do it manually for a selection going > ‘Format’ > ‘Character…’ > ‘Position’ > ‘Spacing’. The default unit is pt and the resolution 0.1 pt. Negative extra spacing is also supported.

A different thing is scaling the width by a ratio (percentage) feasible on the same dialogue tab. It afflicts every single character of the selection.

Leading is the vertical space between lines.
What you are describing is Character Spacing or Tracking.

Your justification options for paragraphs of text are: “Align left”, “Align right”, “Center Horizontally”, and “Justified”, which sounds like what you want: which aligns the left to the left, and the right end of each line to the right, for each line except the last line in the paragraph.

It’s possible you’re not seeing the icon to provide full (flush) justification because the document window is too narrow. You could widen the window, or look for one of the small “>>” icons that indicate a drop-down menu of lots of commands that won’t fit in the area at the top, provided for the various controls.
You could also use Tools->Customise… to adjust the UI so the Justified icon appears.

Or, select Justified on the Alignment tab of the Paragraph Style dialogue.

@mel2016: “… a nice justification, with spacing beetween characters to avoid large blank spaces.”
This given, I did not stress the ‘Justified’ option for paragraphs, but thought the OQ was looking for something known in German as “Zeilendurchschuss”, in English, as I was told; less informative “leading”.
In specific in newspaper print with its narrow columns you sometimes have a single word in a line or a wide space between just 2 words. To get this prettier you need intraword spacing…

…or widening of the individual characters. In times of lead-composition the second option was none. Now it is.
However, it seems the common text processing software doesn’tr support either option by automatisms. User has to control this manually.
There is a faint and uncertain memory of the first way once being supported.

When some text is fully justified, in most Word Processors these days, additional spaces are inserted between words to pad out the line. This can lead to a messy look if there are only a few words on a line.

What you are refering to is microspacing. In this methor microspaces are added between each character to pad the line. It was available in Word Perfect and older versions of MS Word had a setting to use Word Perfect justification (microspacing). It seems to no longer being offered. I was not aware of it being in LO Write. What version was it available in?

You could try the suggestions by @Lupp. Alternatively a good Desktop Publishing program will have this feature. I usually edit the text to get it to look better.

The widening of word gaps isn’t done by inserting spaces but by widening the single space just for view or print.
The automatic “microspacing” was available in StarOffice 5.2 of 2000 and also in LibO V3.3 under the label ‘Expand single word’… It did not apply to lines containing wide gaps between words. V5.3 also offers 'Expand single word, but now only applies it to the last word of a paragraph where I never would use it. Strange behaviour!

@peterwt, you’ve got the stuff “What you are referring to is microspacing. In this method…” in twice above.

Wow, I’m surprised this is not in LO, it’s been around so very long and essential to some editing jobs, like for newsprint styled layouts with narrow columns. I first encountered it in Ventura Publisher running on DOS. That’s how old it is.