General Input/Output Error Opening Excel Document

I’m getting a general input/output error when opening a particular xml excel document. This document is 379407 lines huge. My only feedback is a message box alerting me of the failure, even if I run the libreoffice from the command line. I’ve searched this forum and discovered a common cause for this issue is invalid entity characters in string data. The ampersand “&” being the most common of the problematic entity characters. The “&” is not the case for me in this instance. I’ve reproduced this problem using version and I’ve also tried running xmllint on the document hoping for more information but the document was parsed by xmllint without a problem or warning of any kind. A co-worker that has Microsoft Office using Windows 8 has no issues with the document. I’m using Fedora Linux 22 and have also checked the file permissions. I can read the file using a text editor.

Any thoughts on what the problem might be or how to coerce LibreOffice into generating a significantly more verbose message than “General Input/Output Error”?

image description

<?xml version="1.0"?>
<?mso-application progid="Excel.Sheet"?>
<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"
 <DocumentProperties xmlns="urn:schemas-microsoft-com:office:office">