"Get Involved" nag line

Lately, in LibreOffice 6.1.2.1 I get a nag window on top asking me to get involved.
Are you trying to become obnoxious windows-like software? How do I get rid of that thing?

“How dare you offer your program to everyone, and not shut up, but also sometimes show a bar asking to get involved and help the project?!!”

how i dare?

  • there is a prominent page in this regard on the download page
  • it is embarrassing if this shows up in a business setting, eg on a projector

i don’t mind this in the about box but plastered over the screen is a turnoff

Although I am not (yet) using LO v6, I can’t recall ever seeing such a nag window in LO. Is this a new “feature” in LibreOffice??

yes, it has been introduced in 6.1.

OK, thanks. In a sense, the Questioner has now become involved. Do you know if the nag window will recognize this and now stop appearing on his screen?

:slight_smile: well - great you asked. Interesting thing that the AI in the infobar is not smart enough to see my involvement (although I am bold enough to think I am even more “involved”).

ve3cat: It gets even worse with 6.2. Even if you donate, it will now still beg for more donations every 180 days

Marketing thinks that no one cares about the nagging because statistically they haven’t heard any complaints. I added the “Stop begging” extension to the official templates and extensions website. Perhaps if that gets upvoted enough they will remove their inappropriate method of soliciting.

There is LibreOffice bug report 120271 about this topic (https://bugs.documentfoundation.org/show_bug.cgi?id=120271) which contains an extension that will disable both the Get Involved and Donate infobar messages for LibreOffice 6.1.3+.

If you don’t want to trust an extension, you can do it manually by setting the LastTime* settings to the maximum number 2147483646. In the LibreOffice menu, go to Tools - Options - LibreOffice - Advanced - Open Expert Configuration. Search for lasttime, and change the values for LastTimeGetInvolvedShown and LastTimeDonateShown.

Starting in LO 7.0, there is a new, generic way to disable cetain infobars, including donate and contribute. See https://gerrit.libreoffice.org/c/core/+/92638. This does not impact the current solution, which still works.

Can you explain how do disable the infobars? I visited your link, but I don’t see a way to do it.

See “I added the “Stop begging” extension to the official templates and extensions website.”

That is the easiest way - you download an extension and install it via Tools - Extension Manager.

(see How to install LibreOffice extensions - The Document Foundation Wiki if you need help installing the extension.)

Okay, thanks. I thought there was some new setting inside the LO GUI.
In that case, I would prefer to just enter those values. You said the maximum number is 2147483646, but I was able to enter 999999999999999999. Will it work too?
What are those values, anyway? Seconds, minutes?