Getting BASIC runtime error. Device I/O error

On Fedora Workstation 31 which I have just installed in attempting to run the macro below, I am getting this error message, whIle using a split database and the Java-1.8.0 openjdk.

BASIC runtime error. Device I/O error.

I am running LibreOffice BASE version Version:

I should note that I can run the same file on another computer using Fedora Cinnamon Desktop. And I could run in on Linux Mint 19.3 desktop, I have installed the same program with the macro and it worked.

The actual Macro:
The Error message:
Error message.png

Can anyone help?

Please edit the reformatted and compacted code once more to make sure it is equivalent with the code that produced the error. In specific make clear the final MsgBox statement. It looks skew. Where was the string s defined? Why is the half mile of message at the end inside the loop?


Don’t have your OS but can consistently get the same error in Firebird embedded if the location or name is incorrect. Double check your file path. Seems to be missing something - /home/????/SQL/File1.txt

The error occurs in reality with this /home/username/SQL/File1.txt. In Fedora, I had to add the username in fact as home, as one can create folders directly in the home directory in Fedora Workstation, whereas in in Mint, or Fedora cinnamon, this is not possible. I am quite sure the problem has something to do with Fedora, as the macro still works on another computer with Fedora Cinnamon spin.

I have added a screenshot of the macro visible under my query at C:\fakepath\File1.png and of the error message. I quite think that due to the comment of Ratslinger that this may be due somehow to the manner in which Fedora workstation processes the folder structure leading to the file. Also I added a third screenshot of where the error occurs in the macro.

It is difficult since your code shows /Home/Xxxx..... when it is typically /home/Xxxx.....

You can try print curdir

And yes, that is the same error I was getting whenever the file name or directory was incorrect.

I found the resolution it was due in part to my error, and in part to the way Fedora presents things. In looking in the file manage in Fedora, the directory structure or path seems to be /home/SQL/ and there is no indication that it is not. However like other Linux distros, the path is really /home/USERNAME/SQL/ Thus when I saw the way Fedora presented things in the file manager, I thought I needed to create a new folder with my username, in order that the path in all of my macros be correct. This would make my macros inaccessible since the path would now be /home/USERNAME/USERNAME/SQL/ . Thus in elimating my created username folder, the macros worked.
I thank everyone for their help as it allowed me to look in the proper place to find the problem.