Graphics filter not found

I am running LibreOffice on Windows 8. When I open Writer and Impress when I try to import a jpg from a file it says “Graphics filter not found.” I was running on an earlier version and just did an install of the newest version and I am still getting this error. I checked the FAQ and wiki and could not find any information specific to this error.

Have you done a partial installation?, can you open this graphics files directly browsing in the system?

I can access the images just fine. Opened them via web browser, windows photo viewer, and mspaint. All work just fine.

Just tried completely uninstalling and then reinstalling… same issue. Graphics filter not found.

I recently updated to LibreOffice on Ubuntu. I’m having the same error trying to import a tif file (Graphics filter not found). Strangely, Libreoffice is able to ‘preview’ the image but not insert it into a Writer document. Since I mostly use Writer for technical reports with lots of images, this has effectively rendered Writer useless for me.

Have you tried resetting the user profile?, sometimes solves strange issues.

Just shut down all instances of libreOffice. Removed user profile from my %appdata% folder. Started up libreOffice. I then saw a new folder created in the %appdata% folder. Attempted to insert an image from file (jpg) in a writer document. This resulted in the same error as occurred before “Graphics filter not found.”

I had the same issue as Goblinlord with LIbreOffice Portable and PNG images. Inserting images by the Import menu didn’t work but the drag and drop of image files does. I reset the user profile and it’s working again now.
Nevertheless, I have still an issue with EPS files with which I get an empty frame when I import them in Impress.

For what it’s worth, I started seeing the same error with .EPS files once upgraded to 4.1 :

The bug I reported seems to be Ubuntu specific while you are using Windows.

ditto. “Graphic filter not found” importing image PNG as exported by Dia.

uname -a
Linux fedorabook 3.8.13-100.fc17.x86_64 #1 SMP Mon May 13 13:36:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Am able to import using printscreen and then importing the file.