hardware acceleration greyed out in view options

LibreOffice Version:
Build ID: 1:6.1.4-0ubuntu0.18.10.1~lo1
CPU threads: 4; OS: Linux 4.18; UI render: GL; VCL: gtk3;
Locale: en-US (en_IL.UTF-8); Calc: group threaded

This is the terminal output:
glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.2.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.2.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:


It appears you have OpenGL selected. See → tdf-94552

And how to unselect it? I selected GL in an older version of LO (installed from Ubuntu software center), and menus became unreadable, and I was unable to get back to default settings even from safe mode. I then removed LO, and installed the latest version from ppa. Now I can see menus, but I still can’t get back to default.

The HW acceleration only applies to the non-GL mode. When you enable OpenGL, the setting has no meaning. So it doesn’t help if you could “enable” or “disable” a setting that means nothing in your currently-selected mode (OpenGL). If you have some display problems, first try disabling OpenGL.

Right. So please tell me how to disable OpenGL. That is exactly what I want to know. I don’t find the option for that in LO, because after enabling it, the option disappears.

Well - the Safe Mode should give you the option, and I’m unsure why you couldn’t do that as per your comment. Possibly that was impossible using the older version?

Actually, the OpenGL option should not “disappear after enabling it”; it should disappear when it is unsupported. I suppose you have found a bug, where you had enabled it in an earlier version, where it was possible, but now cannot disable because the newer version doesn’t show you the option because it is unsupported on your system - but oddly doesn’t disable it itself…

Also you should be able to fix it using profile reset.

Submitted tdf#122701. The OpenGL setting is hidden now for gtk3.

@mikekaganski Thank you for assisted comments here. It also appears this can be cleared in Options through LibreOffice->Advanced Then Open Expert Configuration button. Search for OpenGL and change UseOpenGL to false.

Well, safe mode was unable to fix it, and in the older version, I couldn’t read the menus, due to this very issue itself, as I mentioned earlier. But the “open expert config” instructions were exactly what I was looking for, thanks! You should re-post that as the answer.

@Shmu26 Comments attached to an answer are actually part of the answer. In a number of cases the solution for a particular issue is not revealed until further information is provided.