Have you, Lupp, updated the file 15182016016398585.ods

This file was offered in Oct 2014 as I remember.
When I download the file it will open in Trio Office but everything is protected so instructions cannot be followed. Here’s what shows in my file manager are:

Here’s the file as downloaded

My OS is Windows 10 (recently updated) and Trio (libre office 7) was purchased through Microsoft.

PS Could not use attachment tool because system misrepresented the file number to upload

This site is for questions and answers about LibreOffice usage, not for file sharing. Yours is not even a hint to a question. Get a downvote.

@Idury it seems you have a Windows problem, not a LibreOffice problem. Please see How to unblock a file blocked by Windows or search yourself for your own answer.

I cannot understand your question. If you have a question about an answer posted on this site you must link to the question, or at least give the question number.

@gabix: I wouldn’t downvote the question though I don’t undrstand it.
There obviouly are misunderstandings, but probably not an actual misuse of the Q&A site.

@Idury, @gabix, @Lupp, The file link is this:


but I didn’t understand the doubt.

I wouldn’t downvote the question

I have downvoted a non-question here.

Thanks @schiavinatto .
I now remember the old topic, and I tried the download of my old checkPwd.ods with LibO V The result remineded me faintly of another question about problems with the code. I took in account that LibO may have changed the behaviour of loadComponentFromURL with a password. Actually the function now asks for a “better password” if the provided one is wrong. That’s bad for the usage of my old sheet, of course. As recently as 2020-09-20 I addressed the issue again, and found that I could get what I wanted if I ordered the mentioned method to try to open the file hidden. Still no prompt for another password then.

I will now attach the reworked sheet to my answer below, and - if it correctly works also with the re-downloaded file - I will also edit the old thread from 2018,

One of the problems of the OQ may simply be that he had a crash, and the lockfile wasnÄt removed correctly. ~lock.15182016016398585.ods# must be deleted.

Have been a bit slow to respond for your efforts but thank you very much @Lupp. The checkPwd.ods file works now and is fast. Have not found my password but the program example points to a logical way to create passwords – start with a master and use easily traceable ones built from this. I notice you’ve found the original question and corrected the text appropriately. Idury dmckmailbox@gmail.com.

Assuming the question is kind of “meta”:

There seems to be a fundamental misunderstandig. If somebody uploads a file as an attachment to a post in this site, it is automatically disambiguated concerning its name by renaming it to a number without any involvement of the poster. I therefore haven’t the file under that name in my local file sytem, and I don’t know the post or the thread it was attached to. If you give me the needed information, I may be able to check.

Please give a link to the thread from where you got the download.
Retag your question meta.
Don’t ask questions directly addressing contributors in the subject. If you want to draw somebody’s attention on a post, you can include his (f/m) username with a prefixed @ in the post’s body. He should then get a notification of your post.

[edit dt=“2020-12-27 about 14:40 UTC”]
As announced in my answer to the comment by @schiavinatto I now attach a reworked version of the spreadsheet file made for checking supposed passwords for correctness:

Just tested the re-download. Worked as expected.

I also attached the most recent version of the helper file to the top lines of https://ask.libreoffice.org/en/question/145716/.
If there once should be need to ask about a related issue again, please do that either in the linked thread or in a completely new one.
This thread is somehow “malformed”.