having trouble with sumifs

I am using this statement: =SUMIFS(F2:F1859;D2:D1859;”Website Payment”, )

I need the total of column F2:F1859 if “Website Payment” is in column D2.

I am getting a 501 error


LibreOffice Help - Error Codes in LibreOffice Calc states:

There is an extra , (comma) at the end of your formula and

=SUMIFS(F2:F1859;D2:D1859;"Website Payment")

should work.

[Update] (according to comment of @mikekaganski )

Assure that you get standard double quotes, which might have been replaced by setting Tools -> AutoCorrect Options...->Tab: Localized Options -> Double Quotes: [x] Replace by typographical quotes. My advice would be to disable this option for Calc.

Hope that helps.

There are also non-standard quotes around the string literal…


? - you can’t leave off the quotes without getting Err:508

Update: Ah - I see, you mean typographical quotes replacement through AutoCorrect options (forget my comment; I don't like statements like this, but for me the most annoying default setting in **Calc**).

I don’t like statements like this

… and I second you in this :yum:

But regardless of the opinion about autocorrect, Calc is smart enough to not do that when a formula is typed; so obviously that’s a result of a copy-paste from elsewhere into the formula, including the typographical quotes. Thus I just thought it makes sense to point OP to this aspect, to avoid further confusion.

so what opaque said worked. =SUMIFS(F2:F1859,D2:D1859,“Website Payment”)
Not sure what you guys are talking about on the “typographical quotes”

And what is the difference to my answer?

> Not sure what you guys are talking about on the "typographical quotes"

Did you check the path to the AutoCorrect option given in my answer? Just for clarification: There are languages, were quotes do not look like " but something (U+201C - LEFT DOUBLE QUOTATION MARK) or (U+201D . RIGHT DOUBLE QUOTATION MARK) or even more strange typographical conventions. You may need to zoom this text, to see the difference (and your question contains these type of quotes which is not the straight variant " which is Unicode U+0022)

I edited my post to give you credit. I don’t know why the quotes should have been different from yesterday to today. I didn’t do anything different, yet it worked this morning when I tried it. Thanks for the help