Heading Setting Not Working


I have a heading that seems to ignore the paragraph setting ‘Keep with next paragraph’. I have set it, and it is ticked when I view the settings for the style. However, the only way that I can get this to work is by setting the individual paragraph setting on the selected heading. This obviously only adjusts the setting for that one paragraph/heading, not for all. Is there something I’m not doing right?

What exactly happens? Is the heading not kept together with the next paragraph? Have you made sure that the next paragraph isn’t so long that you can’t keep it together with a heading?

This sounds like style/direct formatting conflict. You may have previously tampered with the paragraph Keep with next setting. This prevents further application of the attribute from the style.

Put the cursor in an offending heading where you didn’t touch the paragraph attribute and Ctrl+M. Does this solve the issue? Same with manually adjusted heading. Does the heading remain on the same page as the next paragraph?

Floris, the following paras probably are too long to appear on the same page as the heading, but when I adjust the heading paragraph to ‘with next’ the heading moves to the following page. I would have expected this when the heading setting was this way.

ajlittoz, the default para setting is not ‘with next’, but the style is. To be honest, I have adjusted the two or three that were a problem, and I can’t remember which ones they were. What’s Ctrl+M do? If I notice another one with a problem (or I can replicate it) I’ll have a go.

Ctrl+M clears direct formatting applied to selected text. It’s up to the developers to decide what will happen when a heading and subsequent paragraphs that have to sit on one page, can’t sit on one page. We are just other users offering help.

Thanks, floris.
ajlittoz, the Ctrl+M doesn’t do anything. What do I need to look for to find out what’s happening? The Heading setting is for ‘with next’; the default para style is not - it has widow and orphan at 2 lines.

Is your heading styled with an Heading n? They all have the Keep with next attribute. You mention a "default para style*. Is your text in Default Paragraph Style? In which case everything behaves as expected.

I think I figures out what’s happening. I happen to put on the formatting marks while I was doing a test and noticed that the new lines that I had inserted to push the heading towards the bottom of the page were all heading size as I had inserted the new lines from right next to the heading - which means that all the preceding row of blank lines are formatted with the heading style. As the heading was at the bottom of the page it failed to role over with the next para. However, when I removed all the new lines with heading style and replaced them with normal new lines with default style setting, the heading rolled over as it should. Not sure if this makes sense.

It makes sense because you created a huge block of Keep with next making a single virtual one.

As a general rule, always work with View>Formatting Marks enabled. It helps to see otherwise invisible objects.

You shouldn’t repeatedly press Enter to get a space between a heading and the following text. Modify the heading style: Indents & Spacing tab, enter a proper value in Spacing, Below paragraph. While you’re at it, take a good look at everything you can do on those tabs, you’ll be amazed how that will help you to get your stuff organized.

Thanks. I don’t normally adjust the spacing via multiple new lines. I was just quickly trying to get the heading to the end of the page. However, one or two may have crept into the document causing the issue. Much appreciated. I spent most of my life dealing with an old version of MS Word, so I’m just starting to find my way around the set.