Headings indented when I apply a style

I have a large (more than 100 pages) Writer document (odt). I have been working on it for more than a year using various versions of LibreOffice, always increasing the version, currently (Always on Windows, if it matters.)
When I apply a heading (Heading 1, Heading 2 etc.) style to the text, something like a tab character appears before the heading. Obviously, I don’t like my headings indented, so I delete this “tab character” with backspace. But I find it weird. When I create a new Writer document and apply a heading style, I don’t get this indentation.

I also noticed that “Toggle ordered list” button gets activated on the toolbar, when I apply the Heading style. And it gets deactivated, when I delete the “tab character”. (I do have “Toggle Formatting Marks” enabled all the time.)

How can I turn this indentation/tab character off?

In some recent release, behaviour of Chapter/Header Numbering changed slightly.

Previously, when your headings have no numbering, text was accepted as you typed it. But in newer releases, Writer considers there is always a number, even when void, i.e. you didn’t request numbering. Consequently it applies its generic rule which is to force-insert a separator between the number and heading. Your heading then shifts to next tab stop (either one you defined or the first available default evenly spaced stop).

Fixing it is easy.

  1. Tools>Header/Chapter Numbering
  2. go to Position tab
  3. select Level 1-10 to configure simultaneously all levels (or do it on each individual level)
  4. choose None from Numbering followed by drop-down menu
  5. OK

PS: please change word “Headers” in your question title to “Headings”. These are not the same. A header is text written in the header area at top of page; it is repeated the same on every page.
A heading is a title for a part of the document (chapter, sub-chapter, …).


Works like a charm. Thanks!