Headless conver-to PDF soft-hyphen replaced with zero-width whitespace

i’m working on an webapp creating LibreOffice Documents that i want to convert to PDFs with unoconv and a headless libreoffice.

There is just one problem i can’t solve: The soft-hyphens i include in the .odt are replaced with zero-width whitespaces in the resulting PDF. The Problem is not related to unoconv - i tried it directly with a headless libreoffice (same result). i tried v as well as and‏

i tried another font (Ubuntu) (i use Arial as the body font) as i expected that the missing Arial font on Linux causing the problem (i have the problem on the production server with debian 7 as well on a virtualbox with ubuntu 12.04).

i even installed the arial font in hope it caused the problem due to libreoffice inability to calculate where to set the “real” hyphens without the font file at hand.

strange thing: using LO on my mac (headless of course) produces flawless PDFs. So the problem must be related to either linux or some missing “graphical” package in my server setup. i installed the hyphen-de package which results in hyphens based on the dictionary, but the specified soft-hyphens are still replaced with zero-width whitespaces.

the problem affects both body text as well as text boxes that are used for annotations.

i’d appreciate any hint very very much!

Well I only found one - maybe - relevant bug report: fdo#44410. Maybe your problem is having the same underlying problem?

Can you upload (or send me your test odt by mail) so that I can test if I get same behaviors on my different OSes? (Win8.1, Mac OS 10.7 and Linux Mint)