Hebrew Font Recognition Issue

Greetings All!
Brand new to LibreOffice.
I’m using Windows 10, and have just recently downloaded LibreOffice, but I can’t get it to recognize my Hebrew or Greek fonts. I’ve been using MS Word for 25 years, and Open Office Writer for 7 years. My fonts work fine in both of those programs, but in LO Writer they are only typing as Romanized characters. I have my language settings identical to that of Open Office.
My preferred fonts to use are hebraicall and graecall, both True Type Fonts (TTF). In the LO Writer dropdown menu they only appear as Romanized characters. There are several Hebrew fonts that downloaded with LibreOffice and appear as Hebrew characters in the dropdown menu, but they also only type out in Romanized characters.
Can anyone show me what I am doing wrong?

Are these fonts installed in your (new?) PC?

The LibreOffice lists and uses the fonts installed on the Operating System.

  • Maybe the Uninstalling of the MSOffice removed these fonts.
  • Or - maybe - you have not set the localized settings in your LibreOffice (Righ-to-Left writing, etc)…
  • Are you sure that these fonts are TrueType fonts really?

Hi Zizi64,
Hey thanks for responding!
The PC is not new. It’s 6 years old. I added these fonts to it when I bought it and have been using them ever since. And yes, they are TTFs for certain.
I’ve never uninstalled MSOffice or OpenOffice. The fonts are still in my PC and I’m still using them in MSWord, and on rare occaisions in OpenOffice.
I don’t really understand what “the localized settings” are. I work mainly in English and Japanese, frequently adding Greek and Hebrew words into my documents. For simplicity’s sake, rather than changing the directional writing to R-L, I just spell the occaisional Hebrew words backwards.
I suspect it’s an issue somewhere in the settings because 1) I also have Hebrew fonts that downloaded with LibreOffice, but will only type out in Roman letters; 2) because the fonts work fine in OpenOffice; 3) if I open one of these OpenOffice documents with LibreOffice all my Greek and Hebrew fonts show up as Roman letters. I really don’t know that much about settings.

It is not only a matter of TTF but also of format among the fonts. LibreOffice dropped support for “type 1” fonts several releases back. So, if your fonts are rather old, they may be “type 1” and won’t be handled. What may then happen is LO substitutes for a supported font which may not have the Hebrew block (but it should display the “missing glyph” instead).
Regarding typing backwards, this is not a good idea. I experimented (here LO under Fedora Linux 35) without enabling “Complex Text Layout” in Tools>Options, Language Settings>Languages to try and mimic your routine. Hebrew sequence is laid out RTL as expected (I guess the writing direction is inferred from the characters), though the status bar erroneously reports whatever language is considered default in the settings. Thus writing direction is not an issue as it is automatically switched.

Many old fonts for Windows are badly encoded. They have been ported from the 256-character set (the “code page” era) to Unicode by simply offsetting the “foreign” alphabet into a Private Use Area of Unicode. This has 2 consequences:

  • the characters cannot be entered from Unicode-compliant keyboards (key combinations are non standard)
  • the sequences are not recognised as pertaining to RTL writing, thus your need to write backwards to get the correct visual appearance

IMHO, you should consider using a real Unicode font. I imagine standard Windows system fonts all offer the Hebrew block. The point is to retype your Hebrew quotations with the correct encoding, instead of the biased hack for the font. By the way, how do you “type” Hebrew? Inserting one character at a time with Insert>Special Character, selecting your font?

Hi ajlittoz,

Thank you for your assistance. It really is greatly appreciated.

You may be right regarding the age of my preferred fonts. These are from 1997, and were lifted from an old study suite CD and pasted into my Windows>Fonts folder. As far as being a “type 1” or some other, I would not know. For type they are only listed as .TTFs with no other designation.

I now have Libre Office installed on three of my computers, two on Windows 10 platforms, one on Linux Manjaro. I have this same issue on all three computers which leads me to believe it’s something that I’m doing wrong and not an issue with the computer or program itself.

I have tried Tools>Options>Language Settings>Languages both with and without enabling the “Complex Text Layout.” Either way it will only type Roman letters, and does not recognize the Greek or Hebrew fonts. Nor does it automatically switch to R-L for the Hebrew.

What really baffles me is these languages work just fine in Apache Open Office (as well as in MS Office) on these computers. I just can’t get them to work in Libre Office, even though the language settings appear to be set up identically. It’s discouraging. I would love to be able to use LO for these documents if I can only figure out how.

As for typing in Hebrew or Greek, in Apache Open Office or MS Office I just select the preferred font (Hebaicall or Graecall) at the necessary place in my document and use my standard keyboard; a for aleph, b for beth, g for gimel, and so on and it types as Hebrew characters; the same for Greek; a for alpha, b for beta, g for gamma, and it types in Greek letters. I can switch to R-L typing in MS Word if I enable the Hebrew IME, but with Windows being what it is, that unleashes a whole new set of issues in other areas of my computer.

To rule out any font issue, please attach the font file so that i can peek inside with specialised tools. You may need to force the filename extension to .odt, .pdf, .jpg or .png because this site accepts only a limited number of file types.
You attach a file with the “upload” tool (looking like a mail tray with an upward arrow).

Okay. Please find the two files in question attached.
This is all new territory for me so I hope I’ve done this right. All I have done is in my Windows Explorer I’ve changed the file extensions from “.TTF” to “.odt” by renaming the files.
GRII.odt (49.3 KB)
HEBII.odt (46.3 KB)

This is exactly what I suspected. All glyphs are in the PUA (private use area) of the Unicode BMP (Basic Multilingual Plane). Copyright notice says font was designed starting in 1986; last change occurred in 1997. This font is definitively an “old” font made to fit the “code page” design principle.

It may rely on specific M$ features to be typed because Hebrew characters are dubbed e.g. ‘a" Microsoft Symbol Area’ for aleph.

The consequence is it does not integrate at all with Writer for typing. Display is another issue. Both fonts have 223 characters stored in the PUA. They clearly conflict with each other. If there is no correct styling to disambiguate the font, Writer or the OS will be unable to select the correct one. And if the font renderer is confused, it may select a system font which obviously has no character assignment in the PUA.

Unless there are particular custom glyphs you need, I highly suggest you recode your documents in using standard Unicode. I know this is tedious and time-consuming but, in the end, this is a winning strategy because you can then exchange/publish your document without trouble. All these “hacked” legacy fonts are ugly workarounds causing more problems than comfort.

Here is what is in HebraicaII:

and GraecaII:

To see the images in higher resolution, right-click on it and Open in new tab. You can then zoom in.

Yup. Those are my fonts. At least now I understand what the issue is.
Thanks so much for your assistance with this.

You might be able to set up the on-screen keyboard in Windows 10 with Hebrew language for when you need to use Hebrew.
On Microsoft site Get to know the touch keyboard

Thanks for the tip.