HELP: Auto correct "red squigglies" stop working arbitraily, forum fixes aren't working

First, Grateful for LO and all the work that’ people put into it.

That said: the problem of autocorrect falling off and stopping working is starting to look like a dealbreaker. Am in the throes of my PhD, dealing with large docs, but do so conisistently, with fdefault styling for now.

Not a newbie. Mac OSX 10.13.6, clean LO install as of yesterday, nothing fancy for styles.


  • -have spent hours going through the litany of posts on deleting your user profiles, etc. - tried them all - no good.

  • -Have spent equal time checking all the spelling dictionaries for checkmarks and all that - no good

    • Have verified the styles that are using dictionaries that are valid and show the checkmarks - no good

One Particular: It seems to be only on certain dicuments, however, I have reset absolutely everything to default - checked the dictionairies, everything!

Yesterday, in desperation, deleted the entire LO installation, and reinstalled. Worked for a day, an just now - nada, nothing, zilch.

I am dyslexic, this is paramount for me. Respectfully, I don’t have hours to spend sifting thrrough forums and outdated documentation on running macros -

Can ANYONE please point me toward a clear-cut solution here? Or are there any developers who can werite an easy to use macro to fix this for cash?

This problem seems to be very common in the community.

I’m THAT desperate.

Thank you!

UPDATE: OK, weird and random. Just for a punt, I decided to look if there are any external spellcheckers or extensions.

Installed Language Tool - LanguageTool » Extensions

For it to work, you have ti disable LO’s default ‘Lightproof’ spell checker.
languagetool-test.odt (132.7 KB)

At first it didn’'t work fully as per their tests. Then I disabled Mac os spell checker and Hunspell. Nothing.

Then enabled Mac OS and Huns again, restarted LO.

Dunno what on earth I am using, but the re squiggles are back, with LIGHTPROOF DISABLED.

This seems like an OS conmflict with extensiton or aomething - perhaps some folks more geeky than I will find some clues in all this?

Also: it worked on the doc that was not work - doc specific seems to no longer apply…

What do you mean? Not using styles and formatting everything manually?

Then direct formatting may be playing tricks on your back, like language text being set to “None” or some language for which there is no checker.

If this sounds gibberish to you, attach a 5-page max sample from your real document for in-depth analysis. Make sure the sample still exhibit the problem.

Hi, no I do not format anything directly/manually - am past that one. I use default style ‘out of th ebox’ because my final-draft thesis will be ultimately professional typeset in Quark or Indesign, - to avoid the nightmare that are styles in word processors.

So heading 1 - as it comes, heading 2 - as it comes - and so forth. No manipulations - hence it does not make sense that this disappearing autocorrect would be style-related.

Also, see my update on the extensions - it magically came back - hence again probs nothing to do with styles…

There’s a gremlin in the software with this. A german developer posted a macro to try to deal with it - but getting it to run was close to impossible…

The forums are littered with folks havingh the same problems…

Of course I read your update. But intermittent checking suggests something dealing with declared language for text. So having a look to your document (or better, a subset of it) could hint at the solution.

By the way, neither Language Tool, nor Lightproof are default or built-in. Both are extensions. This means they have their own development pace compared to LO and you should check compatibility carefully.

Do you also use character styles? Otherwise you also have direct formatting.

Which nightmare? Styles originated in DTP apps like XPress. The only difference in Writer is you can’t apply several character styles to a run of characters. A fully styled document (paragraph, character, page, frame and list) is a very good approximation to DTP document, but if any category is not used, you indeed head into formatting nightmare.


SO: is there anyone who knows about the actual anomaly with the plugins I disocvered?

The configuration I posted is now still working with Lightproof off, consistently, (and I have not changed any other configuration or Language settings from before - when it wasn’t working with LP on).

(an yes I am arare they are separate extensions, but LO comes with LP bundled).

First thing is to try and reproduce the issue. So once again, I ask for a sample extracted from your document to study thoroughly the context.

Not on all platforms. At least this is not the case under Windows or Linux.

1 Like