Help no longer works on just installed LO on Win10 build 1067, tried US

I have just installed LO on Win10 Pro build 1067, but I cannot get the built-in Help to work. I have tried US and UK language settings and help installation files. Keyboard is “US”, Locale is NZ but I prefer UK spelling as not all checking works on NZ documents.
I have also installed on a slightly earlier build on Windows 10 Pro on a different PC and cannot get local help working on that either.
I would be grateful to get this working although I guess a list of Regular expressions would do 80% of my questions.

Make sure that the language of the help file matches the language of the user interface selected in Tools - Options - Language Settings - Languages. Both need to be the same bits size - 64 or 32 bits or it won’t work. The language of the user interface and the language of your documents don’t have to be the same. You can have US English interface and have Dutch as default language, Libre won’t complain.

If this answer helped you, please vote it with :heavy_check_mark: (here on the left). That will help other people with the same question.

(In addition to the answer by @floris_v - just in case there was a misunderstanding:)
There is no built-in help for LibO except the linking to the online help site. The offline help must be downloaded and installed in addition. The installer must exactly match the version of LibO (regard also 32 vs 64 bit) and the language intended for the user interface. If you want to switch betweeen more than one UI languages you also should install all the associated variants of offline help. LibO running will then choose the appropriate files automatically. Concerning English there are three variants of offline help to date: en-GB, en-US, and en-ZA (South Africa). You may easily guess correctly with which UI language settings these comply.
Downloading LibO from the default download site you will get offered also the offline help. Check for the language!
If the download was missed or did not work correctly, or your version of LibO is not the currently offered one, got to the (the “old” meaning nothing; even prereleases available) and find there exactly the help installer(s) you need.
If you did all this, but offline help is still not working, there must be a OS problem causing the installer of the offline help to extract it to a wrong path.