Help: Single quote key entering « (french left quote) despite US-English setting!

Single quote key ’ creates french left quote « in LibreOffice Writer despite US-English setting of both OS and LibreOffice!
How can I fix this? Info from LibreOffice Help:
Build ID: 1:5.1.4-0ubuntu1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8)

This is an AutoCorrect option.

To change the setting, go to ToolsAutoCorrect Options..., tab Localized Options.

To disable the auto-quote feature, uncheck the Single quotes and/or Double quotes box.

Alternatively, if you prefer other replacement characters, click on the buttons showing a single/double quote.

If this answers your question, accept it by clicking on the check mark at left. If it has some value to you, please upvote the answer, karma permitting.