Help w/ 2-column table dimensions

Hi,
my single column table of contents looks fine, filling up the entire page. But when I change it to a two-column TOC, the leaders carry on too long, and the numbers are pushed off the right side of the margins (see image and settings). I searched previous posts and read the manual. I’ve edited everything I could think of…Any suggestions appreciated.
cheers & blessings,
G

OSX 10.13
LO 7.3.5.2

Edit: I tried uploading a picture (and tried and tried again and again…) and get an error from the website. Sorry, but hopefully my description is adequate (o:

Uploading: image.png…

For a similar discussion, see @ Index / Columns in LO 6.4 Writer messed up.

It’s better to upload a small sample document (.odt) instead of a screenshot. That will not only show what’s wrong, but also allows us to see why it goes wrong. I made a sample document with dummy text that doesn’t give your problem in a 2 column TOC.

1 Like

There is a long-standing malfunction/bug in the TOC engine. A TOC entry is templated in the Entries tab of the TOC dialog by the Structure line. Click on the T button before the #. You’ll see this tab is set as Align right. Unfortunately, in older releases, this is taken as alignment to page right margin instead of column right limit.

It seems to have been fixed in 7.3.6.2.

2 Likes

Thanks! I updated to most recent mac version (7.4.1.2) and was still getting the overflow outside the column right limits. However, with your guidance I was able to better understand the Structure line and: unchecked the Align Right box, set a Tab Stop position at 3.5", hacking the visual effect I was going for. Thanks again!

Actually, it doesn’t occur in Version: 7.2.5.2 / LibreOffice Community; Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5; CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3; Locale: nl-NL (nl_NL.UTF-8); UI: en-US; Calc: threaded.

You can also set columns to 1 in the TOC definition, but use a 2 columns page style for the TOC. It’s a bit more complicated if you are uncomfortable with page styles.

1 Like

@floris_v: thanks for the remark about 2-column intrinsic TOC. I experimented with 2-column page. I did again the test with 1-column page and 2-column TOC. It works fine and may give a better look in an otherwise single column document.
Perhaps, some setting is stale in user profile.
Reminder: LO 7.3.6.2, Fedora 36 Linux

1 Like

Solution re messed-up columns in T of C and Indexes;

I have successfully migrated from v 6.4 to 7.3 (7.4 is poisonous) and find that 2 and 3 columns Tables of Contents and indexes work perfectly both at the book level and chapter level.

Thanks to all for your help and advice.

1 Like

Thanks for the feedback (always appreciated), but on this site “answers” are reserved for solutions. It should have been posted as a comment.