Helvetica Neue font turns to gibberish in LO 7

I’m on Windows 10, new PC

Installed the latest LO version
And the font Helvetica Neue OTF family that works on other Word processors is turning to gibberish in LO

How can I fix this issue so I can continue using this font? I have a metric ton of documents with it already ;_;
Help please!

P.D. I should also mention that

  • I saw it working while I set up styling using it
  • I had to unistall and reinstall LO a couple times to get the correct language in the UI

How old is your Helvetica Neue? “Recent” versions of LO have dropped Type 1 font support. Check this if you have any technical tool to peep inside font files.

Meanwhile, you can try several workaround to work on your documents (except tuning formatting):

  • remove Helvetica Neue from the system and configure the replacement table in Tools>Options to substitute another font. This does not modify the documents which still reference Helvetica Neue; it only substitutes for display purpose.
  • change the font in your master paragraph style (you are styling, aren’t you?) for another font; the "master’ paragraph style for text is be Text Body or, as a fall back, Default Paragraph Style
  • if Helvetica Neue was defined as your global default AND you don’t override it in styles, change it in Tools>Options, LibreOffice Writer>Basic Fonts (Western)

Will this bug be fixed?

I had the same issue after the update, lost many hours, tried everything, reinstalling the program, reinstalling the fonts several times, many restarts, nothing helped.

Finally, I uninstalled the current version (7.0.4) and installed the previous version (6.4.7). Bingo.

This is not a solution to the problem! But using an answer for your complaint, you made the question “solved”. This is certainly not your intention. So, to make the question unanswered again, put everything in a comment under the question and delete your “non-answer”. Don’t forget to mention your OS.

In fact, uninstalling the new version was the solution FOR ME.

The entire Libre team and all the experts on this forum had a month and a half and they didn’t come up with a solution. I’ve found the only way to fix the problem for now.

In addition, I have not marked the problem as solved. That is probably an error here in the forum.

If there are moderators here, they are welcome to delete my answer, my comment.

I gave the answer to help others so they don’t have to waste as much time as I did.

I use LibreOffice Writer on the PC and the Mac, but will not update the program on the Mac.

First, contributors on this site are not at all affiliated with TDF. They are users just like you. They are not developers and can’t be blamed for not fixing the issue.

Second, this site is not a forum where you start a conversation and exchange ideas with others in chronological order. It is a Question & Answer site, meaning a question is asked and contributors are expected to provide solutions. As soon as an answer is given, the question is automatically marked “answered”, thus discouraging potential busy contributors from answering. This is also why any user is entitled only one answer.

Telling the community the problem is still occurring is useful information, but it should go as a comment under the question. Only you can do that. This will refresh the question. Once done, you can use the delete link under your “non-answer”.

Not blaming anyone.

The thing is, when I have a computer problem, I use Google.

I found this post by Marcus15 via Google.

I also read your comment.

Did you have the Helvetica Neue font and LibreOffice 7 installed?

Any answers like “do a restart” or “do a reset” do not help anyone.

In any case, your comment didn’t help me.

The answer I gave later helps, it certainly is not the solution that I find good, but it DID solve the problem.

It is not a user error, it is not a Windows error, it is not due to defective files, it is a program error.

Uninstall 7 and install 6.4.

If you have a better idea, use the answer function.

End of the announcement.

I run LO under Fedora 33 Linux. There is no Helvetica Neue in the repositories probably because of intellectual property rights. Consequently I can’t test for myself.

Another idea: I will change my document templates and replace Helvetica Neue with Nimbus Sans.

Maybe the problem is also due to the fact that Helvetica Neue is a premium font.

Helvetica Neue for Windows is not the same as Apple’s version, it seems to be a problem font. Why not use Open Sans or Roboto instead?

Not correct. In this case the new program version is the problem.

I have been using Helvetica Neue for many, many years without any problems, on the Mac, on the PC, with Microsoft Word and for a few years also with LibreOffice Writer.

Sure, I can change a font in the future, use a different font, but if I already have thousands of documents that are illegible in LibreOffice, then some clever advice doesn’t necessarily help.