Horizontal bar between paragraphs won't go away with Format>Paragraph>Borders

I’ve seen earlier questions answered about how to remove the horizontal line that you get when you type in a line of asterisks, but the answers provided before haven’t made this one go away. The line moves up to be between earlier paragraphs if I delete or add a border to the paragraphs that it was between at first. Thank you to anyone who can help with this.

sample paragraph with line between paragraphs.odt

Please, edit your question to attach a sample file showing the problem, otherwise it will be almost impossible to know what’s happening on your document.

Thanks for the file. Your problem is exactly what @Lupp says in his answer: you have the “merge with next paragraph” option enabled. Uncheck it as commented by @Lupp and everything will be fine.

And please, don’t use direct formatting! Writer is intended to be used with styles!

Thank you very much!

If you create a bottom border for a paragraph, mostly the option Merge with next paragraph will be enabled. If yo then create new paragraphs only the last one of a sequence having the border set will show the bottom border line.
If you now remove the border from this last paragraph, the one above will become the last one having that format, and will therefore show the border.
If you select all the range under suspicion and remove the bottom border, it should work.

What’s the lesson?
Switch off silly smart features like Replace dashes messing up paragraph formats by implicit changes. That’s silly MS-Office style.
You may also want to switch off the Merge with next paragraph for the Default paragraph style of your standard Writer Template.
Use well designed paragraph styles instead explicitly.
Use Paragraph borders only in the very few cases where they are usful. This may occur concerning lateral borders used to emphasize something.

Thank you very much!