How are page styles connected in LO writer 7.2

With LO writer 7.0 I used page styles without a problem. I modified them, created new page style, and assigned a page style to a page. I upgrade to LO writer and this does not work anymore as expected.

I have, simplified, two page style for the Left Page. Just “Left page” and “Left Page with footer”. I can modify the page style. And assign as specific page, say page no. 1, in to Page Style “Left Page” by double click in the navigator on the selected page style. This works good.

Now I do a similar action for page no.3 “Left Page with footer” and this work good as well. But the page no. 1 is now also assigned to the page style “Left Page with footer”. If I do correct this to select page no. 1 and double click “Left Page” this is good again. But my page no.3 is now also change, undesired, from “Left Page with footer” to “Left Page”.

So it seems page no. 1 and no.3 are, one way or the other, connected, which I do not want.

What happened, and how can I solve this?

Remember that Writer is contents- or flow-oriented. This means pages don’t exist per se but as container for the text. Pages are allocated as needed by text expansion.

Your text can be split into parts where the boundaries are explicit page breaks, i.e. those you added either manually or as a consequence of Text Flow property of paragraph styles.

A paragraph style applies to a part as a whole. Therefore when you assign a page style to the third page of a part, it applies to the whole part. Applying a different style to the first page will again change the whole part.

Left Page and Right Page are somehow different because they are configured to automatically alternate on implicit page break. You then have a different page style on left and right pages but this doesn’t change the principle that you can have only one page style per part.

What you need is to create a boundary between your parts with a “special” page break Insert>More Breaks>Manual Break where you can choose which page style will be active after the break. The usual Ctrl+Enter does not create a boundary.

You must think about the structure of your document. It has probably a front cover, some summary, a TOC, chapters, an index and a back cover. Each of these parts has a specific layout. Therefore, you need as many page styles (or pairs in case of left/right alternation though there are options in page style definition for simple cases) as parts.

Thanks twice @ajlittoz. First to solve the problem. I used menu → Insert - Page break. With manual break I could enter with which Page Style I want to continue. Second for a better understanding of LO writer.