How can I change the thousands separator in my locale settings?

I am in South Africa. I am open to correction on this but as far as I am aware the official decimal separator is the comma and the thousands separator is the space. The set up for South African English gives a point as the decimal separator and a comma as the thousands separator.

Changing the decimal separator in Calc is easy as Libre Office can be set to use the Windows system locale setting but the same is not true for the thousands separator.

As a workaround I have user defined options in my number formatting setup but it is a pain in the neck to keep remembering and it would be nice to be able to change the setting, so is there any way I can get to it? If not, what are the chances of a thousands separator setting alongside the decimal setting in later editions.

Thanks in anticipation.
Fred

1 Like

Were the en-ZA separators changed at some point of time? Or was using decimal separator ‘.’ and group separator ‘,’ always wrong? Anyway, your claim seems to be supported by the ICU locale explorer.

And no, overriding the separators used in a locale currently is not possible (but planned for the future).

The settings for South Africa has been corrected for LibreOffice 6.2.

See this bug

(The date formats still defaults to two digit years. I would prefer proper ISO-8601, but the separator is more debatable)