How can I delete 7 blank pages in Writer document?

I have a document which is 13 pages long. . .and 7 of the pages at the end of the document are blank. . .and will not go away whatsoever. No matter what I do the 7 pages are always still there upon reopening the document. I have been able to reduce the document to 6 pages via reformatting, however, even when I re-save the document it always opens back up with 13 pages. Nothing I have tried has worked.

Is there any way to completely remove the last 7 blank pages so the document only opens with the 6 pages?

Thank you for any assistance you may be able to provide.

Perhaps you have some hidden non printing characters such as a page break. Turn on the SHOW NON PRINTING CHARACTERS (Ctrl + F10) to toggle the settings. Are you saving the documents as .odt files to make certain you remove any spurious settings caused by other formats? … Peter

Perhaps you have a frame, which is anchored to a page. You might not see the frame, if it is empty. Open the Navigator to see, whether such frame exists. Or do you have anchored something else to page?

The suggestion by @petermau concerning non-printing characters was my first thought. My other suggestion may be a bit cumbersome, but it may give you some relief if all else fails.

  1. Open your Writer document, select ALL, and copy the selection into your buffer.

  2. Open a plain text editor, such as Microsoft’s Notepad and paste the entire buffer into this document.

  3. If you are using Notepad, turn off word wrap (this may or may not be necessary, but it can’t hurt).

  4. Go to the end of the content. Place your cursor just after the last valid character. Select from that point to the beginning of the document and copy the selection into your buffer.

  5. Paste the buffer into a new Writer document. Check to see if you have roughly 6 pages before formatting. If so, replace the missing formatting.

Copying to a plain text editor SHOULD strip out all formatting, and the process described MAY strip out unwanted “invisible trash.” Again, this is cumbersome and somewhat of a “Hail Mary,” but it may be worth a try.

Good luck.

Thank you so very much for all of your advice and guidance. So far, the only way I have been able to save the document with only the six pages is via the .ODT extension, which is what Peter suggested. However, if I re-save it as a .DOC extension it goes back up to 13 pages. I will attempt again the Ctrl + F10 and the Notepad idea and the Navigator. Unfortunately, so far the .ODT extension is the only solution that is working to get the Document to the six pages.

Thank you again for all of your awesome advice and guidance.

Please be sure to post your final solution. I would like to know, and I’m sure others would as well.

Has this ever been solved? I find several reports of this problem on this site, but no resolution. I’m still having this problem. Does anyone know if a bug report has been filed?
Joe Henley

If your file is not confidential nor personal, attach it so that we can have a look at it. Open a new question and I’ll upvote it to grant you enough karma points to enable attachments. I prefer not to upvote your "answeré because it is no answer to the original question and this could confuse users.

Thanks! I’ll add the new question with a sample.
Joe Henley