How Can I Delete Comments in LibreOffice

I was sent a document made by Microsoft Word with Track Changes activated. I deleted all the comments but LibreOffice would not save the document with comments deleted. The comments had a big X through each of them, but when I saved the document and re-opened it, all the comments were still present.

Deleted a spam answer for this question by @Hard_Work.

Deleted another spam answer by @Groy1987.

Same thing with @EvaGreenholt

Probably because Edit > Change > Record changes is still set to ON.

LO therefore records that you have deleted the comment by crossing it out, but leaves the comment. Set it to OFF if you don’t want your changes tracked.

Be aware that exchanging tracked changes between LO and MS Word using .doc or .docx files often causes errors. Ask your correspondents to use .odt files instead - at least you can say the problem is not caused by you.

If this helps then please tick the answer and/or show you like it with an uptick.

I can confirm that with Edit > Change > Record changes OFF I cannot delete a resolved comment (comment with an “X” through it). The document is an original *.odt document. The only choices available in the drop-down menu of the resolved comment are: “Resolve; Delete All Comments by [Author]; Delete All Comments; Format All Comments…” Just “Delete Comment” is not one of the options. Libre Office