how can I fix the TS3100USB driver settings so that it allows me to use CMYK for the Colour Model, when printing black text as grayscale on LibreOffice 6?

I’m using fully updated LibreOffice Writer with fully updated Linux Mint 19.3 Cinnamon with a Canon Pixma TS3120 inkjet printer. The printer has both black&white and colour cartridges that are full of ink, and it still prints colour documents using the Xviewer and GIMP applications.

Way back in May, I had installed both the TS3100-series and the TS3100USB drivers from the Canon websites, and they both work. However, I noticed the TS3100-series driver works better for printing colour documents, and the TS3100USB driver works better for printing black&white documents with LibreOffice.

Also, I noticed that when I’m printing colour documents with Xviewer and GIMP, I need to make sure that the Printer Settings use Color Model: CMYK, Ink Type: CMYK Color, and have Ink Set: Both.

But when I’m printing MS Word documents with LibreOffice, I have to use the TS3100USB driver, which doesn’t allow me to print documents in colour, but works if I make sure the Print color is set to “Print text in black” and the Device Properties is set to Grayscale Printing. I can also print full-colour test pages with the TS3100USB driver.

But the problem now is that when I try to print MS Word documents, I’m getting blank pages, even though I have a full black ink cartridge.

I think the problem arises when the Device Properties lacks CMYK for the Color Model, and it doesn’t seem to work when the Printer Language Type is “Automatic: PDF”, with Color: From driver, and Option is set to “Color Model”.

So, how can I fix the TS3100USB driver settings so that it allows me to use CMYK for the Colour Model, when printing black text as grayscale on LibreOffice 6?

Have you tried saving your files as ODT?

Having skimmed through the Mac user manual for your printer on Canon website I do see that under Ink Tips it says:

"Does black-and-white printing use color ink?

Black-and-white printing may use ink other than black ink depending on the type of printing paper or the settings of the printer driver. So, color ink is consumed even when printing in black-and-white"

LO is not a graphics program and is not colour managed so I expect it outputs in RGB which the printer driver converts internally. If you tell the printer driver to expect CMYK and it gets RGB I guess there will be problems.

No, I haven’t tried ODT or docx files yet to solve the problem.

I have learned years ago to never use RGB in the printer settings, also with my old Canon Pixma MP160 printer. Both the Canon Pixma MP160 and Canon Pixma TS3120 printers never work with RGB, but always seem to work when I use CMYK in the printer colour settings. But the weird thing is that LibreOffice has always caused a lot of trouble with my Canon printers on Linux Mint. And it’s always a problem related to the colour, so the solution is either to switch from grayscale printing to colour printing with CMYK Ink type, or from colour to grayscale and Print → Colour → Print text in black. This is the first time that it’s not working.

But when I’m printing documents with LibreOffice, I always have to print text in black. I have never experienced any of these problems on any of my Canon printers when I print documents with MS Word on Windows. These problems are unique to Linux.

Another possible cause of my problems could be that I have Printer-driver-hpcups (HP Linux Printing and Imaging - CUPS Raster driver (hpcups) installed on Linux Mint. I’m running Linux on an HP Compaq desktop PC, but all my printers are Canon.

Actually, it’s clear that something is seriously wrong with both my printer drivers, because whenever I try to print anything with LibreOffice, I can see that there are absolutely no values for any of my Printer options, such as Color Model, Colour Precision, Media Type, Ink Type and Ink Set.

So aren’t you using the Canon driver for Linux (.deb)? See Mint Linux forum question 247471 and Canon

Sorry, I was wrong about the values for the Printer options. I just have to left click on them to see them.