How can I get periods to print at the end of a sentence?

Words in a sentence print ok but the cursor is at the wrong side of the sentence. Letters are ok but periods, quotation marks etc print on the wrong side of the sentences. I think it has to do with the Hebrew default settings but I don’t know how to change them.

The above links seem to help another with the same issue.