How can I make a csv file with Writer and import with Calc

LibreOffice Writer & Calc
Linux Mint 17.2

I tried saving a csv file with Writer, when saving I wrote the file extention as csv, and it saved as .csv.odt. How do I import into Calc?

Hi Luis Pina III

You cannot import the ODT file into Calc; it needs to be plain-text (though containing comma-separated text, of course).

Importing and Exporting CSV Files (wiki Help)

The key on export is step 4:-

  1. Choose (menu)FileSave as

  2. In the File type box, select Text CSV.

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

If you need the csv file anyway, do as @AlexKemp described. If the csv just was thought to be an intermediary helper you may omit it this way:

  1. Select the text you want to import into a Calc sheet. (> ‘Edit’ > ‘Select All’ e.g.) and copy it. (edited)

  2. Go to the appropriate cell of your sheet (or insert a new one) in your Calc document.

  3. ‘Edit’ > ‘Paste Special…’ (Ctrl+Shift+V) > ’ Unformted text’ > ‘OK’ > Select options > ‘OK’

I think you left out step 1a: Copy.

@JKJEngineer : Thanks! In addition: We can even ‘Paste’ (without the ‘Special…’) and keep the formats getting one cell per paragraph. A strange thing I just observed first time (V5.0.2): Th cells filled this way with text in font ‘Liberation Serif’, paragraph style ‘Default’ originally don’t show any font name. Neither in the toolbar nor in the sidebar nor in the ‘Format Cells’ dialogue nor in the ‘Format Character…’ dialogue.