How can I make LibreOffice multi-threaded

LibreOffice is very slow. Even a simple operation on my spreadsheet, such as deleting sheets, takes more than 10 minutes of 100% CPU core usage, completely frozen in process. I cannot even do anything to my other opened documents.

However, it only uses one core. Is it possible to make LibreOffice uses another thread on my different documents such that I can work on those when doing time consuming operations in a document?

There are a number of performance issues with regard to calc, I do not believe that multi-threading is the problem. It would help to give more details of the problem, for example: version of LibO, operating system, size of spreadsheet, type of spreadsheet, is it a normal .ods or some other type like .xls or .xlsx. Has the problem just starting after changing levels of LibO? If it is a large spreadsheet, have you enough memory set? (tools > options >memory) Sometimes there is a problem with anti-aliasing and other graphics settings ( tools >options > view > graphics)

There are a number of questions already about calc performance, and some known bugs. With more details, someone may well be able to help your annoying problem…Peter

They are .ods files which contains tens of thousands of formulae with indirect references where the user can type in the sheet names into a specified cell in order to fetch data from that sheet.

Tens of thousands of formulas using INDIRECT will slow things down, as there are no known cells or ranges that could be listened to for changes each of those formula cells has to be recalculated on every input.

The problem @erAck mentioned is also present in sheets containing lots of formulae calling OFFSET().
The only way I know to go round the problem is to temporarily switch off the AutoCalculate option.

shouldn’t we make @erAck’s and @Lupp’s comment an answer and check it ‘solved’?

I have the same problem,

  • Problem description: Libreoffice uses only one CPU out of many when convert, concat, insert fields in odt documents, I use Unoruntime

  • Installation:
    Libreoffice 4.4

Java version “1.7.0_91” OpenJDK Runtime Environment (IcedTea 2.6.2) (suse-21.2-x86_64) OpenJDK 64-Bit Server VM (build 24.91-b01, mixed mode)

SUSE Linux Enterprise Server 12 SP1 (x86_64)

  • Current behavior:
    it work very slowly, uses one CPU core at 100% percent, and doesn’t use rest CPU cores. This behavior is in linux and windows systems.

  • Expected behavior:
    Libreoffice will use all avalable CPU.

To resolve this challenge in part, if possible, upgrade to LibreOffice version 6 or 7 or more recent. Which support multi-threaded calculation.

Steps to activate multi-threaded calculation:

  1. Using LibreOffice 6 Calc, navigate to ToolsOptionsLibreOffice Calc
  2. Click on Calculate
  3. Under CPU threading settings, check the box next to Enable multi-threaded calculation
  4. Click on OK button

Below is the same answer as above. But with details if you’re interested in those.
Starting with version 6, LibreOffice now support some multi-threads.