How can I make LibreOffice my default for opening documents?

All of my documents are saved in LibreOffice. On upgrading to the latest version, all of my .odt documents are now automatically converting to and opening in Word. Must I now uninstall Word to avoid this problem?

If you using microsoft windows, you can edit default aplication on properties file document doc or docx, and change open with libreoffice writer.

Thanks. I don’t use WIndows.

This is an OS issue and you haven’t mentioned yours. I suppose it’s Windows (which version?) since you have Word installed but it might also be MacOS. Manage that through the file association utility.

Under Linux/KDE, file associations can be modified through the System Settings application, file association component. Just enter the file extension in the filter box and configure which applications (yes, plural) to associate and their precedence.

Alternatively, under Linux/any desktop environment, you can also right-click on a file and select Open with.... You can then choose which application to launch and there is a checkbox to force the association from now on.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

For Windows:

  • right-click on any .odt file,
  • select open with,
  • left-click on Select other application,
  • click on the LibreOffice Writer icon,
  • tick the Always use selected application to open .odt files
  • and press OK

Thanks. I’ve tried this. But since I work only in LibreOffice, it doesn’t make since to have to select it each time I open a document.

For MacOS

  • Single click on file
  • In the menu bar under File click Get Info
  • Scroll to Open With and choose Libre Office
  • Click the Change All box
  • Done for all files of that type

Thanks for assisting. I’ve resolved the matter by uninstalling Word, which I never use, and am closing my question.