How can I move a column in a Writer table?

How can I move a column in a Writer table left or right?

I know that I can…

  1. Make a manual note of the column’s formatting (if different from the rest of the table)
  2. Open the table’s properties
  3. Make a manual note of the column widths
  4. Cut the contents of the column I wish to move
  5. Delete that column
  6. Insert a new column in the required place
  7. Paste the contents
  8. Open the table’s properties
  9. Restore the column widths in the new order
  10. Fix the column’s formatting as required

… But that is both error-prone and tedious (especially if you have several tables).

I imagine that there would be a superior way. I have looked at the Table help page (“Column: Specifies the value to be used for moving a column”), but I cannot figure out what it means! Google has also not helped me.

So, how do I move a column in a Writer table?

I am using Libre Office version, downloaded directly from the official website, on Linux Ubuntu version 12.04.

Thank you.

EDIT: This seems to be a bug, as referenced by @oweng.

fdo#64902 has been marked as a duplicate of
Bug 35570 - Moving rows (and columns too) in tables overwrites content

As far as I know there is no shorter way of moving columns/rows in LibreOffice Writer if using menu Table | Insert… to create a table.

But LibreOffice Calc does support moving and dragging columns:

  1. Mark source cells to move.

  2. ALT+click_and_hold.

  3. Move to target location.

See details:

You can add a Calc table in Writer! Do the following:

  1. Insert | Object | OLE object.

  2. Create new option and select LibreOffice 4.0 Spreadsheet.

Then click on inserted object and Calc is displayed inside Writer. You can create borders in embed Calc etc and of course the work-around solution for Writer: moving columns around.

Is this good enough solution for you?

Good suggestion. This issue of moving rows / columns without overwriting is an old bug (FDO#35570).

@oweng Thanks, I have added a comment to that bug.

@froz, thanks, but it’s not Calc where I have the problem; it’s Writer.

1 -Cut column you want to move
2 -Insert a new column where you want to have the colum you cut before
3 -Paste into the new column

You might consider to place an enhancement request to get a move column (row) functionality. It would be nice to place the bug report number here to enable others to add comments.

Thanks for the answer, but as I have mentioned in my original question, this simplified version is insufficient (the column width is not restored). I shall add a new bug to reflect the bug mentioned by @oweng.

@PaddyLandau - If there is a bug it must be reported and fixed. Thanks for filing the bug.

This issue of moving rows / columns
without overwriting is an old bug

Yeah!, if we can’t do it without overwrite, we go where we want to move some rows, insert a number of empty rows much bigger than that rows, cut and paste that rows into this new space, after we just need clean the empty rows and move is done .

Note: I had to disable alt key of kde [1], although alt key doesn’t worked.


[1] KDE: Disable Alt-Click [SOLVED] / Applications & Desktop Environments / Arch Linux Forums