How can I open a document saved in Freeoffice/softmaker TO LIBREOFFICE?

I switched from FreeOffice/SoftMaker TO LIBREOFFICE/IMPRESS. So, I have files saved in their format. I am not able to open files saved from Softmaker in my LIBREOFFICE.

Any suggestions?

Tks!

Hello,

the following worked for me in a short test (Using a text document FreeOfficeTest.tmdx)

  • Create a copy of the file using extension .docx (-> FreeOfficeTest.docx)
  • In LibreOffice File -> Open
  • Select the file (in my example: FreeOfficeTest.docx)
  • Important step Select filter Office Open XML Text (*.docx;*.docm) - exactly this one. Do not use any filter sounding similar; it won’t work)
  • Click Open

(For other modules of the application proceed accordingly - Freeoffice uses OO XML)

Import tested using LibreOffice:

Version: 6.3.4.2,Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5;
Locale: en-US (en_US.UTF-8); UI-Language: en-US,Calc: threaded

File created using

FreeOffice TextMaker 2018(rev 973.1103) 64bit

Hope that helps.

If the answer helped you to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.

Hi “O”,

When I open the FO doc and do a save as, because it is *** - originally a MSPowerPoint doc-*** . . there is no “docx” choice. So, I tried saving with the a “pptx” extension. Did a file/open in LO, and only the first page opened, and it was distorted large.

So, I went back and did another copy, and forced a “docx” extension, by typing it in. Tried to open in LO, and again only first page comes up in a large format.

Is there a filter in LO, that might change this?

Thx,

@needcoffee247,

If I understand Opaque’s answer well, no need to open the file; just copy the file and change .tmdx by .docx.

If that works, don’t forget to check the mark (Correct answer mark) to the left of the answer to show that your question was solved.