How can I prevent calc from converting tabs to spaces in cells?

I have a CSV file, some of whose cells contain tab characters in their text. If I edit any text within these cells and then exit the cell, the tab characters are automatically converted to spaces. I would like to prevent this from happening.

Where can I disable this behaviour?

(I don’t know how simple this is to reproduce, as I can’t actually work out how to explicitly insert a tab character in a cell in Calc. It may be necessary to create the CSV in some other software.)


Sorry, AFAIK you can not disable this… Workaround to simulate tab could be to use FormatCellsAlignment tab▸Text Alignment

  • Horizontal: Left
  • Indent: adapt according to the need


Csv containing HT (ASCII X09) are a strange idea. Calc cells nowadays can contain HT but since there are no tab positions in cells it cannot be functional. It simply is not displayed at all. This behaviour might even not be specified anyway. Directly editing the cell’s content results in replacing HT with SP (ASCII X20) as you reported correctly.

As long as HT are actually imported into your sheets you may prevent them from being automatically replaced with the nondistinctive space substituting them explicitly with a placeholder of your choice. I suggest to use a RightArrow (like the glyph displayed in Writer for HT when the option is chosen.)


Will do this for C11, eg. returning the result to another cell.

In situ you may use ‘F&R’ with \u0009 in ‘Search for’ and the character of your choice in ‘Replace with’.