How can I prevent the snap grid from changing with zoom level?

When drawing a line or arrow using LibreOffice Draw, and I have snap to gride enabled, if I zoom way in, the snap on grid seems to disappear, causing lines to deviate from the grid or lines to have little jogs. This is very annoying and makes this tool very frustrating to use.

Many other drawing tools, too numerous to mention, have a fixed drawing grid, based on units of measure, and snap to grid allows the lines to be aligned on these grids regardless of zoom level.

Is there a way to prevent this from happening so that the snap grid just enlarges relative to the zoom level rather than disappearing altogether?

Snap to grid seems to be imaginary. It has no effect whatever I try . . .

You should have started a new question, your comment has only a tenuous link with the original question.

The default grid has subdivision that are quite close together and a narrow snap range.

Try changing to these settings as a test, then once you have feel for them, adjust the settings to suit your style and use .

  • Click Tools > Options > LibreOffice Draw > Grid
  • Under Resolution, set Horizontal and Vertical to 2.00 cm
  • Under Subdivision, set Horizontal and Vertical to 2 spaces
  • Under Snap, tick all the boxes and set Snap Range to 20 pixels