How can I remove unwanted master password

how can I remove unwanted master password

Go to to Tools ▸ Options ▸ LibreOffice ▸ Paths and untick the option to save all passwords. It will then ask you if you want to remove the master password.

Helpful - but I found this option (in v. 7.3.3.2) by navigating to Tools ▸ Options ▸ LibreOffice ▸ Security, then clearing the check with “Passwords for Web Connections”.

Sorry, that’s not that simple.
I had to navigate to Tools/Settings/Special/Expert settings, find the password section and set the “HasMaster” boolean value to “false”. It is not for the faint hearted…

My windowsy LibreOffice 7.3.3.2 began to demand to upgrade the master password but I have never set one. No wonder, when I tried anything at Tools/Settings/LibreOffice/Security/ it required master pwd, but it said “wrong password”, and the demand persisted. After the voodoo above the demand ceased.