How can I set LO to use the paper size from printer preferences globally?

I am using LO:
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded

Using CUPS 2.2.6 as a client to a CUPS 1.4.6 server on a 32-bit VM to connect to my Dell laser printer which has a PPD file which is only compatible with 32-bit libraries and cannot be used on a 64-bit system (I wish people wouldn’t think they know better than users who have experience of the actual use case).

Whenever I open the Print dialogue the paper size defaults to US letter even though the printer only has A4 paper available.

if I open properties and tick the box to “Use only paper size from printer preferences” the paper size is corrected. However, this is only set for the current print and is not changed for further printing attempts or other documents. All documents are formatted to A4 by default, but the print dialogue respects neither this nor the printer preferences choice by default, and seems hardcoded to US letter. How can I change this to default to A4 as it’s tedious having to change it at every print.

With CUPS, you should not worry about 32/64 bits drivers because there is a generic one tailored to work with designated printers through “PPD files”. It should work out-of-the-box without your complicated architure with a relay server.

When you configured your printer, did you define A4 for the default?

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

It seems the answer is that the language and locale settings need to be changed from “Default - English (UK)” to “English (UK)”. How odd that there should be a difference between these two when to the average lay person they mean the same!