How can I set up impress remote on MacOS?

Hi there,

I have the latest (7.1) version of LibreOffice, installed on a Mac and I want to set up impress remote. I have tried to follow the details here:

but the setting is not there to enable it on my laptop (there is only “enable presenter console” under presentation. Is there something else I need to do before I enable it? Or is it a bug, in which case I’ll raise it in the bug tracker?


Edit - here is a picture of the settings screen with the setting missing:

[Edit show image]

From Help 6.3 (New help online is too clever and specifies WIN when I search). Cheers, Al

“Note for macOS users: The Help mentions the menu path Tools - Options at numerous places. Replace this path with LibreOffice - Preferences on your macOS main menu. Both menu entries open the Options dialogue box.”

Thanks for getting back to me Al. I had found the correct menu (there is often a similar difference for mac vs windows). I’ve edited the original question to include a screen capture of the settings screen in question.

Can you connect from Slideshow > Impress remote by just pressing the Connect button in the dialog and following the steps in Remote Connection?

Maybe the operating system defines remote connections separately as it does for Options. If that is the case then a quick read-through of How to remote… might show where the setting is if just trying to connect as above doesn’t work.

Hi Al, the Slideshow > Impress remote menu option is greyed out and not selectable. I’ve had a read through the other document and had a good look through the various OS settings that it proposes and can’t find anything of use.

Indeed, this looks broken since we started using macOS SDK 10.15… which made ENABLE_SDREMOTE_BLUETOOTH to be false (see, and that disabled the control (see tpoption.cxx).

Maybe @cloph has an idea on this? Anyway, even if there’s no bluetooth there, Impress Remote also has a WiFi mode, so disabling in the options based on bluetooth support only seems wrong.

As a workaround, please check if enabling EnableSdremote under Options|LibreOffice|Advanced|Open Expert Configuration helps you.

Filed tdf#141313.

Hi Mike, thanks, that has made the impress remote option appear in the slide show menu. Now I’m struggling to connect through wifi - it shows the code on the phone, but when I try to connect on the laptop it lets me type the code and then doesn’t do anything. There is no animation on the button action and it doesn’t actually seem to be doing anything. I wonder if there are other non-bluetooth issues with this?

@ChrisWilson - sorry, I can’t tell you if it’s generally working on macOS, since I don’t have one … From the general considerations, I’d suggest you to try to check your firewall - if it blocks LibreOffice from communicating over the network.

From the Impress Remote help:

Experimental features enabled at “Tools → Options → LibreOffice → Advanced” in LibreOffice Impress.
If you have a firewall please ensure ports 1598 and 1599 are opened.

So please make sure to enabled those.

Also: tdf#84311

Thanks Mike. I’ve messed around a bit (and actually found the impress remote documentation) and I’m still struggling. I think that, reading that it’s better on linux, I’ll try it on a linux machine instead. Thanks again for your time and support on this.

Christian Lohmaier has fixed this issue for versions trunk (future 7.5 series), 7.4.0 beta 2 and 7.3.5.