How can I stop the "currency format" button turning negative numbers red?

I don’t want my negative currency numbers red - ever! I want to change the default currency format that’s applied when I click on the “currency format” button. Unfortunately, when I search, I find answers for changing the currency, e.g. CAD, USD, GPB but my currency format is correct. Also, I know how to change specific cells, by doing “Format Cells…” and turning off the “Negative numbers red” checkbox. But this doesn’t change the DEFAULT. Whenever I click the “Currency format” button, the damn red comes back. I have been through Tools|Options|Language settings, and Tools|Options|LibreOffice Calc and there is NOTHING about the currency format default in there. I would accept an answer that works only for the current document, but something that fixed EVERY document would be preferable.

The default format of the currency format button can’t be individually changed other than choosing the default currency. The actual default format depends on the active locale under Tools → Options → Language Settings → Languages, Language of, Locale setting, but most (if not all) locales use a default with red negatives.

Thank you for answering! It seems odd that they would add such an annoying ‘feature’ without a way to turn it off, but I guess they expect you to use the “Format Cells…” option if you want something non-standard. I tried to search for the location of the language files so that I could hack the Canadian one, but I can’t find it. I gave up. At least I can fix my spreadsheets column by column. Vielen Dank!

Or create a style and apply it to those cells. While in a cell, double-clicking on the style in the sidebar and it is applyed to the cell, and then modifying the sytle it’s for those cell with it.

Thank you, yes I should learn about styles, if I set one up it may be virtually the same as fixing the problem. In fact, if I could customise an “apply my style” button to the tool bar, it would indeed be identical.