How can I use tables with no hyphenation?

When I use tables in Writer, how do I make the tables stop hyphenating words?

Just as you would do it for any text: through paragraph style settings.

If you want to disable hyphenation only in table, look for Table Contents style. For standard text, see Text Body. Disabling hyphenation for whole document is done with Default Style (provided you did not override the setting in some dependent style or you have no direct formatting).

  • Open the style definition (I assume you know how to do it)
  • Go to Text Flow tab
  • Uncheck Hyphenation Automatically box (by default, it should be unchecked)
  • Press OK

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Perfect! Upon more investigation, my problem was in non-breaking spaces from copying and pasting, even with your suggestion, words were hyphenating. My solution had to do with doing a find and replace on the gray vertical lines behind each word that I copied and pasted into my table. Thanks for your help, it led me to the solution quickly!!!