How do I add internal links to a document?

I want to cross reference various statements in a lengthy

Have you looked in help menu under cross reference? Cross-references

The downloadable writer guide from LibreOffice web site should expand a bit more on cross references (look in the index) and other sorts of links. Writer Guides | LibreOffice Documentation - Your documentation for LibreOffice

Cheers, Al

You can use the navigator to jump to specific marked places in your text. Press the F5 key to toggle the display of the navigator, or use the compass icon on the right side panel. For my own work I find that this eliminates the need to insert links in the document itself.

If you still want to insert a link into the content, first identify the spot you want as a target for your link (where you want to jump to when you click the link). If the target is (or contains) an object present in the navigator, it is already prepared as a link target. If not, insert a bookmark.

Select the text you want to act as a link, and pick menu item Imsert - Hyperlink. Click link category Document in the left pane of the dialog. The crosshair icon beside the target field will bring up a compact navigator view. Select your target there and click OK.

I have followed this instruction. But when I click the Text where I’ve added the Hyperlink, it doesn’t automatically jump to the Text where I have the Bookmark.

In the Navigator, I see that it jumps. But on the main document, I don’t experience the jump.

In Web Development, when I place an Anchor link on a Part of the Page, and set the Anchor Text.

On clicking the Anchor Text, it automatically jumps to the part of the Page that has the Anchor link.

I am not experiencing that beautiful transition to the part of the page where I have set Hyperlink and Bookmark in Libre Office.

is there something I’m missing?

1 Like

Try to hold Ctrl when you click the link.
If you need behaviour like in the web-browser consider to convert to html.

For a Writer document it can be disconcerting to click on a hyperlink and be immediately taken elsewhere.

If you are comfortable with that behaviour you can turn off the requirement to press Ctrl. Click Tools > Options > LibreOffice > Security and under Security Options and Warnings click Options button then in dialogue untick the box Ctrl-click required to open hyperlinks and OK

1 Like