How do I assign borders to tables?

I can create a table and specify the borders in the ‘Properties’ line in the Tables drop down menu, but the borders don’t appear in the table I created.

Did you select the table? You might want to select all the cells for which you want the new borders. You have more options if you select the cells you want new borders for and choose Table Properties and select the tab Borders.