How do I change all user file format defaults

I’ve gone this route (using Writer-to-M$ Word as an example) of trying to change all users on a box at once instead of each user individually:

Use a text editor to alter three files in that “registry” folder.

The first is writer.xcd

Open the writer.xcd file with Notepad, and make the following change:

The line that reads as follows . . .


. . . should be changed to read:

MS Word 97

As there are multiple of instances of that entry I’ve changed them all but alas, poor Yorick, it has not worked. Any other options, such as the writer.xcu file (which I could not open to edit) has failed as well. Any suggestions?

It’s not life-or-death but would sure help me out.

Note that you are not supposed to alter the pre-existing files in the share/registry; you are expected to add there some new files with settings override.

Note that what you are trying to do is a sure way to suffering from format incompatibilities and bugs in external format support.