How do I change text color in LO Base table editor?

I have issues with the “dark theme” in Ubuntu 18.3 Cinnamon and need to address the fact that I can’t see unselected text when editing database table data. I’ve registered a bug, but I am wondering if there is a way to directly change text color, like I can for a lot of other visual settings in LibreOffice.

1 Like

Same issue. It is a problem that I don’t think can be fixed from Tools > Options > Libre Office > Personalization. Libre Office doesn’t play well with dark themes. There should be an official one and have it be well implemented.

I am in Manjaro. It is not about the distro, but the office suite itself.

Hello @ccchips,

Do see a bug as tested in Ubuntu 18.04 Mate & Mint 18.3 Cinnamon. However it is not consistent.

Did try various LO settings to no avail but found a strange workaround. Only some of the tables exhibited the problem. With a Dark OS theme most of my tables had white characters and table borders but on a few the characters were black and as the theme darkened (tried various) experienced the same visual you have explained. So far have not found out any difference as to why some tables had different character colors. Did manage to change it.

Opened original table in edit mode. Then created a new table in design mode. Copied all fields in original table & pasted into new table. Saved new table & closed both. Then did a copy on original table & pasted into new table. Selected Append data and then Create button. Table was now completely visible with all data in white characters.

Must be a reason but haven’t got an explanation thus far.

So you have a few choices. Change your theme for now (even if just somewhat lighter); wait for bug fix; or copy and paste tables in manner mentioned above.

This is a bit troubling, considering the database table I have to manipulate has about 10 queries against it, and the last time I went down this road I mucked things up renaming things. I am going to bring this thread to the attention of the bug report thread I have going, because if the problem can be fixed by redoing the database as you suggest, and if (as I have experienced,) the editable queries are unaffected by this bug,, somebody has changed the routines involving the table displays.

Note that this problem started right after I got an update from the LO PPA I am using, and that if I revert to the distribution’s version by way of ppa-purge, the problem is not there. I really hope somebody on the dev team will work on this, because there’s no way I have the time to dig around in the code and fix it myself.

In the end, I gave up on LO Base to manage databases. Using DBeaver or Beekeeper Studio instead and just using base for registering the databases to LO and adding some queries. The dark theme is still a mess as of 2023.

In LibreOffice the operating system dark theme is much better behaved. If not, it can be turned off for LibreOffice in Tools - Options - LibreOffice - View

Yes, that error seems to have gotten better in, but the SQL editor is still displaying black text on the dark theme, when writing in apostrophes or accents.

It is not usable, not even changing the application colors for SQL.

DBeaver and Beekeeper remains my go-to db manager because dark mode works over there.