How do I change the source data range for duplicated charts in Calc 3.5?

I have been using StarOffice/OpenOffice/LibreOffice since the 1990s and have enthusiastically promoted it to friends and colleagues. So, this weekend I decided to upgrade from OO 3.1 to 3.4 and then install LO for the first time (3.5) on this particular machine. This proved a mistake.

I use Calc very heavily and am currently doing a project that requires the production of line-graph after line-graph with data from a detrended correspondence analysis. My normal m.o. is to copy a sheet with all the data and the chart onto another sheet or spreadsheet and then insert the new data in the range the graph refers to or right-click on the active chart and then select Data Ranges and manually change the reference if the data already exist elsewhere. In 3.1, this automatically redraws the chart with the new data and I move speedily on to the next one.

In both OO 3.4 and LO 3.5, the copied graph cannot be redirected to different data. On right-clicking, you no longer get the Data Ranges option but a new Data Table option. Mind you, the Data Table is a nice addition, akin to the attribute tables in a GIS, allowing case by case change of particular records.

It is, however, utterly useless for the kind of mass-production graphing I’m doing, and it should never have been SUBSTITUTED for the Data Range function but ADDED to the choices available on right-clicking an active chart. There is no way to copy the desired data into the Data Table: All the data appear in the first cell. I have been unable to find any way to get around this. With an active chart, I looked under Format and found Data Table, but it’s greyed out and inaccessible.

I found a very clumsy stopgap measure: copying sheets but then entering new data in the ORIGINAL sheet/chart. This is suboptimal, as I am facing trying to put several dozen sheets within one workbook, instead of dividing all this into several workbooks, each with maybe half a dozen sheets (especially since these are large databases with intensive computations in each cell). Another option would be to redesign each chart from scratch for each sheet of data, but that is extremely time-consuming as these are pretty elaborate, non-default charts.

So, I really do not think LO 3.5 and OO 3.4 are ready for the real world of number crunching, and I am just terribly disappointed in what had been, until now, just about my favorite software suite and propaganda project.

This is such an obvious error and it reflects the disconnect between actual statisticians/end-users who do not have the technical capacity to design software and the software authors who are computer scientists or programmers not statisticians or normal end-users and have no way of imagining what people are actually doing with the s/w.

Mary Palomar

PS: Where can I find a download link to an older version of either LO or OO? I want to uninstall LO 3.5 (I already dumped OO 3.4) and go back to the perfectly serviceable 3.1.

PPS: A note to developers of the install s/w – please create an option in there to install the new edition of s/w w/o removing the older edition – it would have been wonderful to be able to switch versions as I discovered this bug and then go back to the newer version to explore new features. Some s/w allows this – LO should, too. Now I’m stuck trying to get an older computer fired up and my files moved over so I can use OO 3.1. What a nightmare.

You just need to double click on the chart (the border changes to thick grey) and then right click on the chart area to get the Data Ranges.

Hope this helps :wink:

Hi, Pedro, that’s how it’s supposed to work but no longer does. This method works if I want to edit a graph’s data ranges, IF the data I want to edit are the original data. It doesn’t work if I copy the graph and THEN right-click on the chart area – there is no longer a Data Ranges option, just a Data Table option. I can’t substitute data into the copied table, only the original graph/table. Mary

I have the same problem.

As a workaround, I have found that this works:

Duplicate the sheet containing the chart that you wish to copy.
Double-click the chart in the newly created sheet. (Data Ranges are now available).
Edit the data ranges and point them back to the original sheet.
Copy the chart and paste it back onto the original sheet.

Data ranges are available and you can delete the copied sheet.

Interestingly, the newly created chart can be recopied on the original sheet and seems to work the way you wanted originally.

This workaround was a lifesaver, but it is still not exactly what is wanted. AFAICT, this
workaround still does not offer the DataRange option, only the DataTable option on the
chart copied from the newly created sheet to the original sheet.

I am a rather new user of OpenOffice, and even fear I am on the wrong list since I know
nothing about “Libre Office.” Anyway, it’s hard to believe a bug as serious as this is still
around after so many years. I’m using “Apache OpenOffice 4.1.0”.

Hi Mary

I’ve had the same problem. Trying to create blank template multi-sheets with a couple of charts on each. Just kept getting the same “date table” glitch on each new sheet.
I tried several other packages without any luck until I d/led the lastest Libre Hooray! It works just as we’d expect it to. Files seem to port back to O.o and work fine there now.

@MaryP – Does the latest release of LibreOffice still exhibit the same problem? Please let us know!

I can confirm that the sheet copy problem is fixed as of version 4.3.7~rc2-0ubuntu1~precise1. I tested this on Ubuntu 12.04.

Hi Mary P., one add-on to PPS: in your question. You can install more than one LO version. How to do it see this link.

Hy Mary Palomar,
maybe some help in this thread: