how do I delete all headers in a document

Libreoffice changed all headers into “convert” for each page. I want to delete headers from my document. This is the crazist thing I have ever seen. It should be easy just to delete the header! I know libreoffice is crazy, but this takes the cake!

The problem is I don’t understand how “convert” happened either. It just appeared that way when I opened the document one time. Every page header was named “convert,” and a page number. I can’t get rid of them unless I spend all day doing it, and for what purpose I know not. When I try it, in only gets rid of the checkmark, not the damn word “convert.” Now only default shows when I click styles-- page. There is no right page, left page, or anything else anymore.

I am trying to get the chapter name entered into the right page header, and it won’t do it. It just repeats the same chapter, or puts the chapter number in; anything else besides what I want. I thought it was obvious that books have the title on the left page header, and a chapter on the right. I don’t understand why the makers of libre office don’t recognize that and make this easy, instead of making it the most complicated and unmanageable thing I have ever seen.

I tried to delete all the converts in page styles too; spent time deleting them all, and now they are all just back. The styles page sometimes show header left, but header right. My attempts to modify this in the organizer tab accomplish absolutely nothing.

Somebody asked me why I use crazy software. I wonder why the makers of this crazy software don’t come on here and answer these questions, instead of other users who are apparently in the dark as much as I am.

I recently downloaded the newest version of Libre Office 7.1.2 and I am also confused to the audacity of page hijacking led by the forced inclusion of “headers and footers”. Much to my dismay, I researched the solution and found NOTHING but multiple response of pompous hyperbole - PLURAL. Most of us will obviously not pack an 8.5x11 page with words, top to bottom and without spacing or break, but if that be writers decree, it should be accommodated. I poked around Libre for about 20 minutes and decided I didn`t like it, (or its pompous supportees which failed to include any available answer other than their own conjecture) - which brings us here. If you can’t beat them, join them, we have opinions and options.

My best answer as a hardened 20 minute veteran to the OP or anyone landing on this page and running version 7.1.2 would be to search the included; Press F11 > Right-Click mouse on “Header and Footer” > Select “Modify” or “New” > Explore, I gave up and installed OpenO.

“Heading” and “Header” are terms often confused, which leads to mistakes both in the use of Writer and when responding to questions here. I suspect that you don’t really need to delete headers, nor headings. You most likely need to make them work together. You did not attach a document to demonstrate your issue, so I’ll just explain based on the most common case I see.

Automatically generated “Convert xxx” names is a telltale that the file has been saved in “foreign format”, as also indicated by Mike Kaganski. The most common cause is saving as MS Office file. The most common place for the resulting “converts” is in paragraph styles. Other causes exist and other consequences have been seen.

From your posting It looks to me like you type the chapter heading into the page header. Don’t do that. The proper way is to type the chapter heading as a normal, single line paragraph within running text. Then apply the paragraph style Heading 1 to that paragraph. Shortcut key for applying Heading 1 is ctrl+1.

To repeat the chapter heading on following pages, insert a chapter field in to the page header.

  • First activate page header for the page style you are using, if you didn’t already do that:
  • Menu selection Insert - Headers and footers … - Headers - page style .
  • Then insert a field as placehoder for the chapter name:
  • Menu selection Insert - Field - More fields…
  • Select tab Document
  • Item Chapter, format Chapter name and make sure level=1
  • Click Insert button and then Close.

I believe most of the “convert” mess is created when Writer tries to open a docx file, not when saving to docx. When working with your product, save your work in progress as odt always. Only save as docx when you must (for submitting to your publisher?) and keep your odt file for future edits. This reduces the buildup of “workaround residue” to a minimum.

When you insert a new chapter heading (by applying Heading 1 again) the subsequent pages will have the new chapter name in the page header. This approach also translates well to Word files without excessive need of “convert” workarounds, in case you must save as docx.

The reason why this workaround is necessary: Word has a simpler approach to styles, without distinction between text and paragraph styles, and page layout handled partly by direct formatting and partly by style. Thus, there is no provision for storing complete Writer style info within Word’s native formats.

Under Insert → Header and Footer → Header you’ll find a list of all page styles in use, with a check mark on those where headings are active: remove the check mark from those page styles you need to “clean.”

Libreoffice changed all headers into “convert” for each page

I don’t understand what do you mean by “changed all headers into ‘convert’” so, please edit your question (don’t use an answer for that) to add more information describing in more detail your problem. Tell us what you did, which file format you use, etc.

/me guesses that OP uses some external format for storing documents, which adds to the confusion of a newbie.

And what, pray tell, is OP?

OP = original poster

Libreoffice changed all headers into “convert” for each page

If you save your documents to formats other than LibreOffice’s own ODF (which is capable of storing all features of LibreOffice), then you are guaranteed to face incompatibilities in many aspects; and in a specific domain of page handling, there’s a huge incompatibility in the underlying concepts in LibreOffice Writer vs MS Word.

Writer has a great feature absolutely missing in Word, which is page styles. Writer allows to use the styles, where Word uses some ad-hoc properties saved in place and which cannot be reused, without names, etc. Word’s formats (developed by MS, and which aren’t something LibreOffice could modify) don’t provide for storing this information that LibreOffice creates and uses. So when exporting, LibreOffice tries its best to create something that looks at least similar to the document which was created in it, but it’s limited with what is available in the target format. So much is necessarily lost in this case.

If you open that document later, LibreOffice, again, needs to match the information in Word’s format to Writer’s internal representation using page styles. It converts unnamed pile of ad-hoc page settings into page styles, and naturally cannot come with anything other than some “convert*” stuff.

If you then will save this all to ODT, even then you will have a legacy of the conversion artefacts that your document is now filled with. In that case, it’s sometimes easier to start from scratch.

When you are new to a program, it makes sense to start using it as advised - at least until you are familiar with it enough to be able to overcome additional complexity caused by storing to external programs. If you expected to find just a “free Word”, it’s the fallacy of you - because you simply had wrong expectations. LibreOffice is not and in not meant to be a clone of MS Office. It’s a different product, based on different concepts, which is capable of creating documents (like other office suites), but it doesn’t try to mimic other suites’ behavior (and thus it may do more in some areas, and less in others, and uses different workflows, which have a learning curve).

And yes, I understand, that this is not an answer to “how do I delete all headers in a document”. I just try to help OP to realize the reason for some of OP’s troubles, which is insisting on using DOC(X) formats when OP isn’t yet comfortable with the program’s concepts.

Possibly it should have been better posted to this question instead.

The main reason for anyone to use libre office is as a free alternative to word. It has the capability to convert to Word, and if so, it should be compatible. Even when I’m not converting, and when I tried to start over with a new download, I could not begin a new document with the same text and start over. When I follow the instructions on inserting headers, nothing happens. That includes using page styles, fields and so on. This program is very unstable and inserts what it wants to rather than what I ask. It is very difficult to work with for large projects. If I am storing some small item or writing a small essay, Libre office works fine. But for major projects it is not intuitive. Telling me to use it as advised makes no sense, because no one here or online has been able to provide any useful advice. Unfortunately, Libreoffice is not accepted by publishers and editors; I wish it were it might make things easier.

I had to enter almost every heading by hand, and deal with arbitrary changes I did not make, but which libreoffice thrust upon me. It cuts off sentences near the end of a page and leaves huge spaces. It often does not keep corrections that I make. So I don’t think libreoffice is a very good program. I don’t trust MS Word much either, being from microsoft it is liable to also be full of errors and unnecessary updates for which you have to pay that don’t improve anything. That’s how it is with windows too. I wish people here would realize that libreoffice is a difficult program, and people here should not scold or constantly ask for more information when what was asked was clear and concise. Help people deal with what is not an intuitive program. It is far from the only program that has these problems. In my opinion, programmers should not introduce too many arcane and esoteric elements by conform to what people know. Sorry but I have been frustrated; yelling at the computer doesn’t work

The main reason for anyone to use libre office is as a free alternative to word

This is just a false statement based on your own perception. People here who have much experience both in own use of the suite for own needs, and in helping numerous others asking questions here, know many more different reasons. So trying to declare own intention to be “the main reason” is just false.

That others could not give you advises is just because you asked no useful questions. If you asked a simple question like “Here is a link to a document; I need this; I try doing this and clicking there in my LibreOffice version XXX; and I get that what is not what I need”, then you would definitely get a useful advice, including a sequence of actions to get the desired result.

Some of you guys are good as scolding people and asserting your greater knowledge, but do not provide any answers that might help.

Some of you guys are good as scolding people and asserting your greater knowledge, but do not provide any answers that might help

Another false statement, based on your own perception.

Just click on “Users” link at the very top of the page, and then open a profile of any of the high-ranked users there. Then see how many people felt that the answers those users gave were useful. That just depends on the quality of the question asked. For good questions, good answers could be provided; for poor questions, nothing but a link to the manual may be given (and you already got those links elsewhere).

UPDATE - I figured it out!
GO to the Styles menu > Styles and Formatting at the bottom of the menu. The 4th icon from the left is Page styles, and there you will see all of the “Converted 1, Converted 2” … etc… you can shift selct all of them and right click to find the delete command. That will delete the unique headers and footers on your pages. Whew!

I’m having the same problem as the OP. I’ve been asked to properly reformat a large Word document. It came into Libe Office with a different header for almost every page. It is possible that a different chapter tag was used in these headers or amybe the original author manually entered text, and the Libe Office import converted each to a separate header. Most are empty, but they’re all titled “Header (Converted 8)”, and so on up to 28 headers, I can find no way to apply the default header formatting to these headers. I can see the list under Insert> Header, but when I select “Default header” I get a message asking if I want to delete the header, then I’m scrolled up to the top of the page and the header I tried to replace is untouched. It apears that I will have to edit each of these headers manually. I even tried selecting all of the contents and pasting into a new odt document, but the headers were copied and pasted too. Frustrating.

1 Like