How do I disable auto-update for LibreOffice?

This morning when I opened LibreOffice there was a banner announcing it had been updated to Version 7. Last night when I went to bed it was on Version 6 and I did not update anything on my computer at all yesterday or this morning. I assume that some sort of auto-update feature has been added and I’d like to turn it off. I know that keeping software up to date is generally a good thing but given that this copy of LibreOffice is on a work-critical machine I’d like to keep complete control over the process. I’m running it on Linux Mint 19.2 64 bit. As you can see from the screenshot, I’ve looked in the options menu but there isn’t an option visible to turn this feature off. One other thing that may be relevant; this version of LibreOffice is not the one bundled with Linux Mint but a separate one that I downloaded directly from the website.


LibreOffice never updates itself. What you are talking about is a function of your MINT operating system, which obviously had updated its repository with the new version of LibreOffice. Hence you need to turn to Mint’s package manager. Check the manual on how to lock packages and thus preventing them from being updated.

Hint: If you are using synaptic, there is an option [x]Lock Version at menu item Package

[Update] You may also have choosen sudo add-apt-repository ppa:libreoffice/ppa which always installs latest (fresh) version of LibreOffice - using something like sudo add-apt-repository ppa:libreoffice/libreoffice-6-4 will keep your packages at a specific release.

Hope that helps.

Thanks for the speedy response! You’re completely right, I had forgotten to lock the package…

In response to your update I went through my system to check again exactly what happened. I’ve now realised that the version of Libreoffice that updated itself was not Version 6 (which I added myself separately to run in parallel) but an older version that came pre-installed with Mint. It updated my shortcuts, which is why I was confused. Anyway this proves that it is definitely a Mint rather than a Libreoffice issue. Thanks again for your help.