How do I disable paste via middle mouse button?

This ‘feature’ has messed up many letters, and my manuscript. This has happened often, and the results are often hard to find. Anytime I am scrolling down with the middle mouse button, I might push a bit too hard. And then the paste funtion will dump unwanted stuff in some location that i have scrolled past.

Please make this a disable-able option

As I know by default it is automatic scrolling, you can find the option in:

Menu/Tools/LibreOffice/View/Mouse/Middle mouse button