How do I fix double click to highlight?

A while back it was possible to use the hightlight tool by double clicking words. I used to use this feature
a lot but have not been able to get it to work for several months. I have completely deleted LibreOffice and
related files, reinstalled, I am even now working with a completely fresh Linux system with everything newly
installed and it still doesn’t work. As a comparison, I installed OpenOffice and that feature works,
so I am pretty sure it’s not related to my desktop environment (xfce). Really do not want to switch
for this once feature especially since file compatibility see very lacking in OpenOffice. I have searched
around and can’t find any solution to this problem. Hoping I can get some direction here.

EDIT: I realize I left out some important details and wasn’t totally clear.

The problem is that with the highlight tool, I can’t double click a word and have it be highlighted in the desired color, say yellow for instance.

I am currently using LibreOffice Version: Build ID: 6.1.4-1. I run it in Manjaro Linux with Xfce4 4.13 (although when I originally posted, these versions were different, the problem persists)

UPDATE: I have now tried it out in the following setups. Same issue in all of them. I have also included the VCL info because it was brought up.

Manjaro / Xfce 4.13 / LO Build ID: 6.1.4-1 / VCL: gtk3

Debian Testing / Mate 1.2.03 / LO Build ID 1:6.1.3-1 / VCL: x11

Manjaro / Lxde / LO Build ID: 6.1.4-1 / VCL: gtk2

Win 10 / LO 6.1.4 (I had more info about the Win10 version, but my note app deleted it between Win and Lin and I don’t feel like rebooting into Win to get it again)

I can’t see the issue, in writer if I double click on a word it is selected.

Same as @mariosv. Double-click a word, it’s selected.

The problem is not selection, but double clicking with highlight tool to have the word highlighted in say yellow.

@erik_sk: independently from the bug fix, if your highlighting is to be part of the final document (not a reminder marker for something to edit), you should consider setting this highlight in some character style. You can then centrally control the appearance of the highlighted sequences.

ajlittoz: The thing I need to do is highlight many individual words for vocabulary focus for my Korean students. I am not sure how useful setting a style would be. It is possible to click/drag select to highlight, but it was much quicker when the app was able to do the double-click highlighting.

@erik_sk: what you describe is the typical use case for character style. It has an explicitly intended purpose and a semantic meaning. Using a character style involves sightly more clicks than mere highlighting (when it works) but you gain versatility. Since it is not direct formatting, you can change everything from a single location (the style definition) and it applies instantly to all occurrences (font face, size, colour, highlight, background, effects, …). For instance, if you see you mischose the colour, you don’t need to hunt every usage.

OK, here’s what I think erik_sk wants (and me too). In OpenOffice, and Adobe Acrobat, when I double click a word with the highlight tool selected, it will automatically highlight the word. I dont mean highlight it blue for selecting text, I mean highlight it (usually yellow) for making text stand out. I want to do this with LibreOffice. Right now when I double click a word with the highlight tool selected, it selects the word in blue, and unselects itself from the yellow highlight formatting tool. I just want to highlight one word in yellow by double clicking it. I do this frequently in other formats. Why not LibreOffice. Is there a way to do this? Maybe a hack?

Works for me as described: highlight tool selected (cursor turns into a paint bucket), double-click a word (it gets highlighted). Note the highlight tool must be deselected after use with an extra click on the toolbar icon.

Possibly that’s OS/VCLplugin-dependent? it doesn’t work as described on Windows; it deselects the function there as @WhiteBear describes.

OP should have cited his OS :frowning: and maybe also LO version.

I supposed I should have been a little more clear in my original query.

Indeed, the problem is that with the highlight tool, I can’t double click a word and have it be highlighted in the desired color.

I am using LibreOffice Version: Build ID: 6.1.4-1. I run it in Manjaro Linux with Xfce4 4.13

I don’t think this is a Linux distro or DE problem though, because I have used Xfce for a long time and I know this feature used to work in the past. I suppose I could try installing some other DEs and trying them to see if there is a difference, but I don’t look forward to all of the uninstalling after if there isn’t any difference.

I don’t now about this VCL plug-in, but I am going to take a look. It’s something to try.

I don’t think Xfce is to be blamed: I have it installed on one of my older computers and LO runs fine, but I never use highlighting on this backup computer. I’ll test it.

Works as expected with Doesn’t work with Testing on Win10. Needs a bug report and bibisecting.

Filed tdf#122442.

What works for me on 7 (cannot test on Linux) is to double-click to create a selection (word/sentence/paragraph/multiple words, etc.) then single left-click the highlight tool.

All selected text is highlighted.

Hey FYI, I get the same misbehavior on both my laptop and desktop. Here is the info from my laptop:
Version: (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 10.0; UI render: GL;
Locale: en-US (en_US); Calc: CL

Fixed in tdf#122442.

I am very excited to see this. But I am wondering how I can apply it to my setup. I looked at daily builds and the options for Linux are deb and rpm. I use an Arch based distro, so neither of those will work for me. I am not afraid of going in and editing files in my system, just not sure where it would be.

The patch has been pushed to master branch, so it will be in 6.3. Also, backports to 6.2 and 6.1 are prepared, and need review (and if they will be approved, they will go to the next versions of relevant branches - 6.1.5 and 6.2.1 resp.). Of course, you may make your own build of LO, and apply the patch manually - to start, you need to follow this guide.

I took a look at the guide. Not fully getting how to apply patch. The only mention of it in there seems to apply to BSD. I guess I will have to be patient and wait for the updates. Thanks