How do I fix the font size?

When I use Writer the font sizes are not working properly when selected. Size 12 appears as 20 and to get to a size 12 font I need to select 6 or 7. The default is set at 12 for writer documents but this is not working as described.

To ask questions as wiki posts makes no sense. How should someone else know better what you want to ask?
In what way did you determine/measure the “real size” the text is put to?
How is the font size 12 described for you?

What version of LibO are you using on what opereting system?

Please dont use the “answer” feature to give additional information. Edit your original question instead.

Do you perhaps have the zoom level (bottom right of the status bar) set too high?

Thanks BigRai You gave me the answer that worked.

Copied my comment to an answer.

I have a similar problem with LibreOffice on Windows 10. On an A4 page I have a table of 8 cells (2x4) which just have 1st, 2nd 3rd etc in them in Times Roman 96pt (st, nd,rd, and th are all superscript). They all work perfectly except for 6th where the digit 6 is clearly a much smaller font but says it is 96pt. I’ve tried deleting and re-entering, painting the format from other cells,copying and pasting from another document (where the numbers all show the same size) and cloning the format but nothing works. Anyone got any suggestions?

You perhaps have the zoom level (bottom right of the status bar) set too high.